Page MenuHomePhabricator

Design survey for reading list usage in Android
Closed, ResolvedPublic

Description

Background

Reading lists has been in place in Wikipedia Android for almost a year, and whilst we have some stats on usage, it would be beneficial to receive more feedback on what lists are being used for and how multiple lists are being used.

To gather more detailed user feedback, we will create an in-app survey for users of the reading lists feature.

Planning doc

https://goo.gl/LYChrJ

Survey assets

To do

  • Planning doc
  • Determine user groups to target and set timeframe for survey responses
  • Create reading list usage survey on Google forms
  • Create survey card copy and image
  • Clear survey verbiage & update link to privacy statement from Legal
  • Release survey
  • Analysis and write-up of responses: https://goo.gl/nC5NpX

Details

Related Gerrit Patches:
mediawiki/services/mobileapps : masterAdd Android and iOS reading lists user surveys

Event Timeline

RHo created this task.May 8 2017, 5:07 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 8 2017, 5:07 PM
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Aklapper reopened this task as Open.May 9 2017, 10:19 AM

Copying over thoughts from Josh and I on the email thread:

From @JMinor:

Some specifics:

  • Target audience? In app survey card/google survey? Email to the already volunteered user testers?
  • Questions... use of reading lists, motivations for reading lists, importance of bandwidth and offline?
  • Timing.... assume we want to get this running soon, since descisions are being made now. Is next week too quick to target having the survey ready to run/up and running?

From @Fjalapeno:

We are currently speccing out the Reading List service, and while we have some stats on usage, we don’t really know “what” users are using Reading Lists for.
Bookmarks?
Offline?
Study?
Commenting?
Professional?
Travel?

RHo updated the task description. (Show Details)May 11 2017, 8:29 PM
RHo added a subscriber: Nirzar.May 11 2017, 8:35 PM

Thanks @RHo the survey questions look good. I left a couple small comments in google doc, but otherwise I'd say "ship it"!

RHo added a comment.May 15 2017, 6:57 PM

Thanks for the comments @JMinor – Just reviewing the goals of the research now, I wonder if you think it may be worthwhile to run a similar survey in iOS (with reference to multiple lists removed and naming changed slightly)?
We may benefit from comparing the usage of offline reading lists of users with one vs multiple lists...

@RHo I'd lean to just doing Android first, to keep things simple. We can always run an iOS specific survey when we start development in earnest for iOS next quarter. But if you think its useful up front, I wouldn't stop you ;)

RHo updated the task description. (Show Details)May 16 2017, 7:09 PM
RHo updated the task description. (Show Details)May 16 2017, 8:03 PM
RHo updated the task description. (Show Details)May 16 2017, 8:30 PM
RHo added a comment.May 16 2017, 8:44 PM

hi @JMinor – We can proceed first with Android, though the iOS version of the survey was not actually that long to create... take a look and see what you think: https://goo.gl/nHLydb

RHo updated the task description. (Show Details)May 16 2017, 9:03 PM

@RHo seems good to me. Since you already drafted this and it was easy, I'll make a subtask for iOS.

RHo updated the task description. (Show Details)May 19 2017, 10:02 AM
RHo updated the task description. (Show Details)
RHo updated the task description. (Show Details)May 19 2017, 10:12 AM
RHo added a subscriber: Mholloway.EditedMay 19 2017, 10:25 AM

hi @Mholloway – looks like we are ready to release this survey for reading lists so would you be able to add it to the MCS endpoint? Ideally it would be great to deploy so it's out for the weekend if possible! :) :)

The assets are in the description, but here's the text for the survey card for ease of copy paste:


Survey image: https://commons.wikimedia.org/wiki/File:Reading_list_survey.png

Hi Android readers,
Have you been using reading lists? Help us learn more about how you are using them by taking a short survey, so that we can continue making reading lists even better.
[No thanks (hides card)] [Take survey (goes to survey https://goo.gl/DlKuLW )]

Survey powered by 3rd-party service; see privacy statement.


o/ I'm happy to do it but Release Engineering has a rule against Friday deployments except in exceptional/emergency situations. It's probably not going to happen without manager-level intervention (ping @Fjalapeno).

If Greg signs off on it I'm happy to get it out the door posthaste.

RHo added a comment.May 19 2017, 4:22 PM

s/w Corey @Fjalapeno and no intervention magick-can-do, so shall we instead wait until next Thursday deployment? Would be good to time survey to catch more active weekend users...

Yes, I'd say lets wait for a weekend.

I put a reminder on the cal for next Thursday's services deployment window.

bearND added a subscriber: bearND.May 22 2017, 7:32 AM

@JMinor What is the desired start and end date/time for the survey?

Hey @bearND the survey should run on both platforms May 26th-28th inclusive (ie. start at 12:01 May 26, end at 11:59 May 28). Please see the subtask for the iOS wording, click-though URL and image link.

Change 355528 had a related patch set uploaded (by Mholloway; owner: Mholloway):
[mediawiki/services/mobileapps@master] Add Android and iOS reading lists user surveys

https://gerrit.wikimedia.org/r/355528

Change 355528 merged by jenkins-bot:
[mediawiki/services/mobileapps@master] Add Android and iOS reading lists user surveys

https://gerrit.wikimedia.org/r/355528

RHo updated the task description. (Show Details)May 29 2017, 5:00 PM
RHo moved this task from Incoming to In Development on the Design board.
RHo closed this task as Resolved.Jun 28 2017, 11:45 AM
RHo updated the task description. (Show Details)
RHo moved this task from In Development to Done on the Design board.Jun 29 2017, 12:50 PM