Page MenuHomePhabricator

Improve visual design and streamline workflow of the Share-a-fact feature
Closed, ResolvedPublic

Description

Designs provided, ready for dev

Background

Share-a-fact is in need of a visual design refresh so that it is consistent with the look and feel of the updated Android app.

Proposed design updates

1. Updates to visual design

  • Update typography throughout
  • Branding (placement and treatment of Wikipedia wordmark)
  • Image and card licensing information per T91811, T164957

See Zeplin for redline mock examples: https://zpl.io/GaRQKKV (tagged "Share-a-fact")

2. Improve discoverability
Allow user to select 'Share-a-fact' from the article level overflow without having to select text first.

3. Feature enhancements
The following suggested changes/enhancements allowing greater control in the design of the share-a-fact cards may improve usage of the feature:

  • Add ability to select a different image from the article if it contains more than one image (or even select none)
  • Allow change to the zoom and crop of the image

Related tickets

Event Timeline

Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
RHo renamed this task from Improve share-a-fact to Improve visual design and streamline workflow of the Share-a-fact feature.May 10 2017, 5:11 PM
RHo added a project: Android Design.
RHo updated the task description. (Show Details)
RHo moved this task from Needs Triage to Design Doing on the Wikipedia-Android-App-Backlog board.
RHo triaged this task as Low priority.
RHo moved this task from Design Doing to UX Debt Backlog on the Wikipedia-Android-App-Backlog board.
RHo removed RHo as the assignee of this task.Apr 25 2018, 1:46 PM
RHo raised the priority of this task from Low to Medium.
RHo removed a project: Design.
RHo updated the task description. (Show Details)
RHo added a subscriber: RHo.
Dbrant claimed this task.