Page MenuHomePhabricator

RDF dumps do not have 'latest' link
Closed, ResolvedPublic

Description

Unlike JSON dumps, RDF dumps of Wikidata do not have "latest" file link on https://dumps.wikimedia.org/wikidatawiki/entities/. I think it's time for us to add it. Same can be done for truthy NT dump.

Details

Related Gerrit Patches:
operations/puppet : productionAdd "latest" links to TTL dumps

Event Timeline

Smalyshev created this task.May 8 2017, 7:22 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 8 2017, 7:22 PM
Smalyshev added a subscriber: hoo.May 8 2017, 7:28 PM
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Aklapper reopened this task as Open.May 9 2017, 10:19 AM

I don't think we should add this before we declare the RDF dumps stable, thus I added T112127: [Story] Move RDF ontology from beta to release status as a subtask/ dependency for this.

I'm not sure how these two are related. Stabilizing ontology may take a while, and people will be using the dumps all that time anyway, but they'd have to manually browse directories. Not sure why not help them and make direct link?

I don't like to have stable links with BETA in them (like https://dumps.wikimedia.org/wikidatawiki/entities/latest-all-BETA.ttl.bz2), thus I would prefer to add https://dumps.wikimedia.org/wikidatawiki/entities/latest-all.ttl.bz2.

I don't think having "BETA" in the link is such a huge deal, but I'm fine with any link name, provided it exists and points to the latest ttl dump.

Lydia_Pintscher triaged this task as Medium priority.Jun 11 2017, 6:22 PM
Lydia_Pintscher moved this task from incoming to ready to go on the Wikidata board.

Change 358783 had a related patch set uploaded (by Smalyshev; owner: Smalyshev):
[operations/puppet@production] Add "latest" links to TTL dumps

https://gerrit.wikimedia.org/r/358783

Change 358783 merged by Filippo Giunchedi:
[operations/puppet@production] Add "latest" links to TTL dumps

https://gerrit.wikimedia.org/r/358783

Smalyshev closed this task as Resolved.Jul 11 2017, 9:31 PM
Smalyshev claimed this task.

Seems to be working now.