Improve documentation for CodeMirror extension
Closed, ResolvedPublic3 Story Points

Description

Current documentation: https://www.mediawiki.org/wiki/Extension:CodeMirror

Please update with the following goals in mind:

Let's put the documentation for end-users (editors) at https://meta.wikimedia.org/wiki/Community_Tech/Wikitext_editor_syntax_highlighting. That should include:

  • Provide a color coding key explaining what the available highlights are, and how they're colored.
  • Explain how a user can override the CodeMirror styles with their own styles (via their user common.css page).
  • Some screenshots
kaldari created this task.May 8 2017, 10:40 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 8 2017, 10:40 PM
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Aklapper reopened this task as Open.May 9 2017, 10:19 AM
DannyH triaged this task as Normal priority.May 16 2017, 9:50 PM
kaldari updated the task description. (Show Details)May 16 2017, 11:53 PM
kaldari set the point value for this task to 3.
Niharika moved this task from Ready to In Development on the Community-Tech-Sprint board.
kaldari updated the task description. (Show Details)Jul 11 2017, 6:39 PM
kaldari updated the task description. (Show Details)Jul 11 2017, 6:51 PM

@Niharika: The new end-user documentation looks great. We still need to update the extension documentation though. See the first 3 bullet points in the description.

@kaldari: We are directing our beta feature users to the talk page on mediawiki and the features page on meta. This is inconsistent. We should fix this.

== Integrating other extensions with CodeMirror ==
If your extension adds a special tag or code and you want to make sure CodeMirror highlights it, you can make your extension depend on CodeMirror. Here's [https://gerrit.wikimedia.org/r/#/c/348673/ the first] and [https://gerrit.wikimedia.org/r/#/c/350840/ the second example] for doing this.

[[File:Pride and codemirror.png|300px|thumb|Screenshot of Syntax Highlighting in English.]]
[[File:Codemirror hindi.png|thumb|300px|Screenshot of Syntax Highlighting in Hindi.]]
[[File:Codemirror popup.png|thumb|250px|Screenshot of Syntax Highlighting with the popup for first-time users.]]

@kaldari I don't have any idea how the integration stuff works. The above is what I can add to the page. Is there anything you'd like to add to that?

@Quiddity Hey! Can you help me update that page now? It still gives me weird Translate errors if I try to update it.

Add the below after 'Configuration parameters' section.

== Integrating other extensions with CodeMirror ==
If your extension adds a special tag or code and you want to make sure CodeMirror highlights it, you can make your extension depend on CodeMirror. Here's [https://gerrit.wikimedia.org/r/#/c/348673/ the first] and [https://gerrit.wikimedia.org/r/#/c/350840/ the second example] for doing this.

And update the screenshots gallery with
Pride and codemirror.png
Codemirror hindi.png
Codemirror popup.png
(Remove the existing screenshot)

Thank you!

Done. Plus I split up the To do list, so that adding/removing new items won't invalidate the whole block. :-)

kaldari closed this task as Resolved.Jul 12 2017, 10:56 PM
kaldari moved this task from Needs Review/Feedback to Done on the Community-Tech-Sprint board.