Fill scrolling gaps in syntax highlighting, take out larger font size and spacing for headers
Closed, DeclinedPublic5 Story Points

Description

When you scroll very quickly, CodeMirror shows big white "gaps" because it can't process what's supposed to be in your browser view quickly enough. This is distracting and will be annoying for power users.

Fill in the space by showing regular unhighlighted text as the screen goes by. To do this, we'll have to take out the larger font size and line spacing for headers, and make it uniform size and spacing.

I liked the treatment on headers, so this is a shame, but we can't have those "gaps"; people will hate it.

DannyH created this task.May 8 2017, 10:56 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 8 2017, 10:56 PM
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Aklapper reopened this task as Open.May 9 2017, 10:19 AM
DannyH triaged this task as Normal priority.May 9 2017, 11:21 PM
DannyH edited projects, added Community-Tech-Sprint; removed Community-Tech.
DannyH set the point value for this task to 5.
kaldari raised the priority of this task from Normal to High.Jun 15 2017, 9:20 PM

While I agree this behavior is annoying - it's probably a tough problem too. Even sites like Twitter/Facebook can't load fast enough if you scroll too quickly (that is not to say we shouldn't think about it). I don't know how often people will load the editor and scroll down very quickly - but I don't imagine that number to be very high.

What are the possible cases when someone will do this? Ryan mentioned one in our meeting - users will do that if they want to add a category to a page when they don't have HotCat. Again, I doubt how many power users would do that.
Is there a chance we can user test this first?

I agree this is probably not easy to fix, but @Pastakhov might know better.

I will be able in a couple of days and take a look on it.

I cant replay the problem
I took the large article and copied one several times for increase size of article even more.
Then I moved from beginning to end of article using mouse and ctrl + end buttons and could not see any "gaps".
http://test.foxway.org/w/index.php?title=Sandbox:T164809&action=edit

How should I replay the problem?

You should be able to see it by scrolling the mouse quickly. I looked at your test and could reproduce it.

Can't reproduce.
Tested on CPU Intel Core i5-2430M CPU @ 2.40GHz
FireFox 52 and Chrome 51 on Linux 64-bit.

Maybe I should use slower CPU for reproducing.

I can't reproduce either but I'm on a MacBook Pro, whereas Danny is on a somewhat dated MacBook Air. That might be the problem.

DannyH closed this task as Declined.Jun 26 2017, 5:48 PM

Yeah, if this is too hard to reproduce, and probably more trouble than it's worth, I'll mark it declined. Thanks for your investigation work.

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptJun 26 2017, 5:48 PM
DannyH moved this task from Ready to Done on the Community-Tech-Sprint board.Jun 26 2017, 5:48 PM