Page MenuHomePhabricator

'Quick links' - blank names for saved filters
Closed, ResolvedPublic

Description

  1. On RC page select some filters and click the 'Quick links' button
  2. For the name of a filter press spacebar several times - the blank name will be saved.

Details

Related Gerrit Patches:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 11 2017, 11:57 PM

A SPACEBAR.

You know, @Etonkovidova, I've tried to set up guards against empty strings, and nulls, and make sure nothing can be saved if it's empty -- and the thought that someone would put in several spaces as a name to cheat the system into saving an empty query seriously never occurred to me.

My faith in humanity is inversely proportional to my faith in your ability to find the weirdest user-behavior available.

Change 353488 had a related patch set uploaded (by Mooeypoo; owner: Mooeypoo):
[mediawiki/core@master] RCFilters: Treat saved query with multiple spaces as empty

https://gerrit.wikimedia.org/r/353488

Change 353488 merged by jenkins-bot:
[mediawiki/core@master] RCFilters: Treat saved query with multiple spaces as empty

https://gerrit.wikimedia.org/r/353488

Check in betalabs - the issue is fixed:

  • not possible to save blank filter names
  • leading/trailing spaces spaces are truncated, including extra spaces between words (e.g. 'test[3 spaces] 1' will become 'test 1'

QA Recommendation: Resolve

jmatazzoni closed this task as Resolved.May 27 2017, 12:04 AM