"Cancel" button in action=edit must not look like a red link
Closed, DeclinedPublic

Description

I now see the green "publish" button in mediawiki.org. However, the "cancel" action has become a red link, rather than a blue link. As everybody knows, a red link is a link which brings you to a 404: you click it only if you want to create the page. The styling is inappropriate for MediaWiki and does not achieve the expected outcome of conveying that clicking the link is a "destructive" action (clicking a red link is usually a constructive action).

"Cancel" should either be a blue link again, or be of another colour, or become a proper button with whatever background is wished.

Nemo_bis created this task.May 12 2017, 6:41 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 12 2017, 6:41 AM
Elitre added a subscriber: Elitre.May 12 2017, 7:28 AM

Well, it's close to the other action buttons, it's bold, and it's not in a place where people expect a red link to be placed so that they can create a new page. If anything, I find the opposite is true; as the color now helps me understand the intention, I can find my way around more easily while editing on wikis on languages I don't understand without having to change my interface language first (assuming of course that in the meantime I also hit my head and forgot where the Cancel link is usually located, that is). If using red for anything that is not a wikilink is an issue in general, it shouldn't be discussed here, since frameless, label-only, destructive red link is a thing in OOjs UI.

Sidenote, I've seen 3 comments from people that they hadn't realized there was a cancel feature until the link (previously black) became red.

Jdforrester-WMF closed this task as Declined.May 16 2017, 9:07 AM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

Per above.

frameless, label-only, destructive red link is a thing in OOjs UI.

Where else is it used?

Sidenote, I've seen 3 comments from people that they hadn't realized there was a cancel feature until the link (previously black) became red.

I can confirm this. I was editing for years before I noticed there is a cancel button, fourth button next to the holy trinity of save, preview and diff

I noticed a color of OOUI buttons was slightly modified over time and the checkboxes were redesigned completely, maybe the color of red button without a frame could be adjusted a little to be more different from a red link

stjn reopened this task as Open.Jul 6 2017, 9:40 PM
stjn added a subscriber: stjn.

Reopening this per suggestion from @Nemo_bis. The fact that it is more prominent for newcomers does not justify the fact that red quiet buttons right now looks as red links in the interface, which is deeply unacceptable, especially there also can be a literal link for "Editing help" right besides it. And with it definitely looks as one of the links is non-existent, which is not an intended effect.

As I said in T162849, OOjs UI should've not gone from previous standard and should’ve used a black button which turns red by hover. It would’ve avoid the confusion and still would’ve show that action is destructive.

Screenshot: https://i.imgur.com/xa0AA79.png

Elitre added a subscriber: Deskana.

Reopening this per suggestion from @Nemo_bis. The fact that it is more prominent for newcomers does not justify the fact that red quiet buttons right now looks as red links in the interface, which is deeply unacceptable, especially there also can be a literal link for "Editing help" right besides it. And with it definitely looks as one of the links is non-existent, which is not an intended effect.

As I said in T162849, OOjs UI should've not gone from previous standard and should’ve used a black button which turns red by hover. It would’ve avoid the confusion and still would’ve show that action is destructive.

Screenshot: https://i.imgur.com/xa0AA79.png

Hey there. As you can see above, I disagree, and Declined this task earlier. I appreciate that you don't think this was the right choice, but we have already considered the arguments you made as they're the same as Nemo did. Do you have a further argument that I haven't considered? If not, I will re-close this.

stjn added a comment.Jul 10 2017, 6:28 PM

Hey there. As you can see above, I disagree, and Declined this task earlier. I appreciate that you don't think this was the right choice, but we have already considered the arguments you made as they're the same as Nemo did. Do you have a further argument that I haven't considered? If not, I will re-close this.

Sorry, I have reopened this by Nemo’s suggestion. I thought that it was appropriate to leave feedback based on opinions from members of the community where WMF rolled out this change (namely, Russian Wikipedia), and they raised the same opinion as Nemo − current cancel button looks like a red link or, as one community member said, ‘text of strange colour’ [1].

If we have provided a better way to test this new panel than via &ooui=1 − I guess I would’ve made this feedback earlier, but I think that

  1. as per my screenshot above, there were links previously in that part of the page, so there could be a red link;
  2. even if there wasn’t a chance to have a red link in that place, it is still a design inconsistency since red links are integral part of MediaWiki design; if anything, it is an argument to get rid of all quiet buttons, if making them black by default is not a preferable option for WMF designers;
  3. experienced users (since they are ones that will be editing across multilingual projects) do not need the button to be red to find it faster in other languages, because it is fourth button from the left or from the right by default.

If this needs to be discussed anywhere else, then sure, but it needs to be discussed and current occurrences of such design problems should be, in my opinion, get rid of. Feel free to reclose this issue, I am as always arriving after the party’s over and people on Phabricator obviously do not like that (I already met something like this during RevisionSlider rollout) and I can only grieve over this.

[1]: https://ru.wikipedia.org/wiki/Файл:Описание_изменений_2017-07-05_(кнопки).png (translation from Russian in quotation marks)

It looks like a red link (which is a big ‘no’ against any red quiet buttons) and it draws too much attention to the element which is not the most useful in the form.

Taking this comment from the other task. Adding to what @Elitre said, context is decisive. If it were not close to the other buttons and not set to bold, I'd tend to agree. But it's an action at the end of the page close to three other page-specific actions, it's labelled “Cancel”, which is a well-known, often used interface action concept (same for Russian user interfaces I guess).
To the point of “drawing too much attention”: Accidentally clicking “Cancel” could lead to potential data loss – one of the worst error conditions in information systems. Therefore gaining users' attention by indicating the action with a signal color is useful.

Jdforrester-WMF closed this task as Declined.Jul 18 2017, 6:23 PM

In consideration, I'm going to Decline this again.

Though I appreciate that there is a possibility of expert edits getting confused, I'm more concerned about newer users. Red links are a concept for content and should never apply to interface components like this. Thank you for raising it, however.

Tgr added a subscriber: Tgr.Jul 20 2017, 8:44 PM

FWIW clicking a red link while you are editing a form destroys your work just the same clicking a blue one would (you navigate away, and the browser might or might not remember what you entered when you return) so I don't see how it could mislead the user about the destructiveness of the action.