Page MenuHomePhabricator

Highlighted items in a default saved query always appear on refresh
Closed, ResolvedPublic

Description

One more bug with fix for review and QA.

To reproduce:

  1. Add a new saved query that has items that are only highlights (not selected)
  2. Make that query the default
  3. Clear all filters, add anything else without the highlight that is in the saved query
  4. Refresh

Result - the query you refreshed appears, but the highlight from the saved query also appears on top of it.

This is due to us merging the saved query parameters+highlights over the URI params, but the URI params doesn't have the highlights set to 'null' if they're not there, which causes the default to override the state. Fix is in the task.

Details

Related Gerrit Patches:

Event Timeline

Mooeypoo created this task.May 13 2017, 8:26 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 13 2017, 8:26 PM

Change 353711 had a related patch set uploaded (by Mooeypoo; owner: Mooeypoo):
[mediawiki/core@master] RCFilters: Always put highlight values in the URL

https://gerrit.wikimedia.org/r/353711

Change 353711 merged by jenkins-bot:
[mediawiki/core@master] RCFilters: Always put highlight values in the URL

https://gerrit.wikimedia.org/r/353711

@Mooeypoo the exact issue described in the ticket is fixed:

Result - the query you refreshed appears, but the highlight from the saved query also appears on top of it.

QA Recommendation: Resolve

jmatazzoni closed this task as Resolved.May 27 2017, 12:05 AM