Page MenuHomePhabricator

Source editor fails to load on direct non-view page loads where the wiki doesn't have Single Edit Tab enabled
Closed, ResolvedPublic8 Story Points

Description

I am greeted with this message "The editor will now load. If you still see this message after a few seconds, please reload the page. " when I try to edit the source. The editor won't load and reloading won't solve the problem.

First, I thought this happened when I chose to edit in VE, press Escape to quit VE (since it takes lot of time to load), and use Edit Source option, but now, it is happening without selecting VE.

Details

Related Gerrit Patches:
mediawiki/extensions/VisualEditor : wmf/1.30.0-wmf.1Always prefer wikitext for action=edit on non-SET wikis
mediawiki/extensions/VisualEditor : wmf/1.30.0-wmf.1Fix action=edit links for NWE
mediawiki/extensions/VisualEditor : masterAlways prefer wikitext for action=edit on non-SET wikis
mediawiki/extensions/VisualEditor : masterFix action=edit links for NWE

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 14 2017, 10:33 AM
Urbanecm triaged this task as Unbreak Now! priority.May 14 2017, 11:44 AM
Urbanecm added subscribers: Vojtech.Vesely, Mates, Urbanecm.

Can confirm it at cswiki (me, 2017 editor enabled but this happens only if the old editor is in the URL, @Vojtech.Vesely and @Mates. It started appearing from yesterday or so.

UBN as this priority is for things that worked before and breaks normal usage of the site.

Please fix this ASAP.

Details:
Browser: Google Chrome 58.0.3029.96 (64-bit)
OS: Kubuntu, 16.4, 64-bit

Restricted Application added subscribers: Jay8g, TerraCodes. · View Herald TranscriptMay 14 2017, 11:44 AM

I've noticed now that the URL after reloading isn't just action=edit but action=edit&venoscript=1 so it is turning some ve scripts. Tagging visualeditor then.

Clear and exact steps to reproduce, as a step-by-step list, are always welcome, plus full URLs.
I cannot reproduce, but maybe my steps are not correct?:

Urbanecm added a comment.EditedMay 14 2017, 2:28 PM

Okay, here are the steps.

  1. Go to https://cs.wikipedia.org
  2. Ensure you have New wikitext mode enabled in your preferences
  3. Click at the search bar
  4. Search for nonexistent page (I've tried searching for Loremipsumdolorsitamet)
  5. You are at https://cs.wikipedia.org/w/index.php?title=Speci%C3%A1ln%C3%AD:Hled%C3%A1n%C3%AD&search=loremipsumdolorsitamet&searchToken=1ysu1er5lux31orn6h57i3d9u
  6. You'll see a redlink in a sentence like Můžete stránku Loremipsumdolorsitamet vytvořit nebo požádat o její vytvoření.
  7. Click at the redlink
  8. You are at https://cs.wikipedia.org/w/index.php?title=Loremipsumdolorsitamet&action=edit&redlink=1
  9. You'll get this error message Editor se nyní načte. Pokud tuto zprávu stále vidíte po několika sekundách, prosím obnovte stránku. (in English The editor will now load. If you still see this message after a few seconds, please reload the page)
  10. Try to reload the page using F5
  11. The message would be still in place
  12. Click at the link from "obnovte stránku" (in English "reload the page")
  13. Note that the URL has changed, from https://cs.wikipedia.org/w/index.php?title=Loremipsumdolorsitamet&action=edit&redlink=1 to https://cs.wikipedia.org/w/index.php?title=Loremipsumdolorsitamet&action=edit&redlink=1&venoscript=1
  14. The editor would load as-expected.

I've tried this multiple times, everytime with the right result. However, clicking at "Založit zdroj" which links to the new editor always work correctly.

Can you reproduce it now?

Note that I'm not able to reproduce the problem without having the New wikitext mode enabled so it is related probably.

Please merge T165236, it's on the same problem

Thank you a lot for the great steps! Confirming.

Does this only happen when you end up on a " Create the page "Loremipsumdolorsitamet" on this wiki! There were no results matching the query." page (because of wrong URL parameters), or also in 'other' situations?

So if I try to summarize in one sentence:
The "Create the page" link on the "zero search results" page is
https://cs.wikipedia.org/w/index.php?title=Loremipsumdolorsitamet&action=edit&redlink=1&uselang=en
(which does not load the new wikitext editor) while it should be
https://cs.wikipedia.org/w/index.php?title=Loremipsumdolorsitamet&action=edit&redlink=1&uselang=en&venoscript=1
in order to work.

@Aklapper Please read the description of the merged task: T165236 The issue's not the same for all the users. And it seems it has something to do with the wiki settings, since on enwiki I didn't notice any problems at the first glance.

In ukwiki and dawiki clicking on any redlink with 2017 editor enabled brings up a page with the message "The editor will now load. If you still see this message after a few seconds, please reload the page" and the editor doesn't load. If you click the "reload the page" link, the standard wikitext editor will open. This is easy to reproduce, but I'm not sure if it's the same for everyone using the 2017 wikitext editor.

https://cs.wikipedia.org/w/index.php?title=Loremipsumdolorsitamet&action=edit&redlink=1&uselang=en&venoscript=1
in order to work.

Still it doesn't load the 2017 wikitext editor, you have to press "Create source" to load it

Thank you a lot for the great steps! Confirming.
Does this only happen when you end up on a " Create the page "Loremipsumdolorsitamet" on this wiki! There were no results matching the query." page (because of wrong URL parameters), or also in 'other' situations?
So if I try to summarize in one sentence:
The "Create the page" link on the "zero search results" page is
https://cs.wikipedia.org/w/index.php?title=Loremipsumdolorsitamet&action=edit&redlink=1&uselang=en
(which does not load the new wikitext editor) while it should be
https://cs.wikipedia.org/w/index.php?title=Loremipsumdolorsitamet&action=edit&redlink=1&uselang=en&venoscript=1
in order to work.

In fact any redlink is broken that way for me.

With 2017 editor turned off the message is shown sometime too but it seems to be random.

Elitre added a subscriber: Elitre.May 14 2017, 7:14 PM

@Piramidion, note that the task T165236 happens for the 2017 wikitext editor while I have not selected that feature and I am still experiencing this issue.

InsaneHacker added a subscriber: InsaneHacker.

Hm... didn't notice this issue yet with 2017 editor disabled

TheDJ added a subscriber: TheDJ.May 14 2017, 10:17 PM

Possibly related to: T165132

@TheDJ, T165132 is due to the New Editor which I did not enable. I am facing this issue when I try to use the old editor.

@TheDJ, T165132 is due to the New Editor which I did not enable. I am facing this issue when I try to use the old editor.

I'm unable to reproduce this. @Urbanecm above has provided some steps to reproduce the issue, but step 2 says:

Ensure you have New wikitext mode enabled in your preferences

Yeah, seems my steps are for another issue... I expirienced this bug with using OWE only but it behave randomly. I know that anything cant be truly random but it looks like that... I'll examine it.

@Piramidion It happens a) everytime VE is selected, and after it loads, cancelled by pressing Escape and clicking on Edit Source b) randomly when Edit Source is clicked.

geraki added a subscriber: geraki.May 15 2017, 9:58 AM

I confirm the same problem exists in elwiki. Users report that they face it even after they disabled the beta wikitext editor.

The issue is with non-singleEditTab wikis, hence not broken on en.wiki. Investigating...

Frwp had this problem too.
For user reports, see https://frwp.org/WP:bistro and search 'éditeur'.

Jdforrester-WMF renamed this task from Source editor fails to load to Source editor fails to load on direct non-view page loads where the wiki doesn't have Single Edit Tab enabled.May 15 2017, 10:50 AM
Jdforrester-WMF assigned this task to Esanders.
Jdforrester-WMF set the point value for this task to 8.
Jdforrester-WMF moved this task from To Triage to TR0: Interrupt on the VisualEditor board.

Change 353854 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/VisualEditor@master] Fix action=edit links for NWE

https://gerrit.wikimedia.org/r/353854

Change 353854 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Fix action=edit links for NWE

https://gerrit.wikimedia.org/r/353854

Change 353858 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/VisualEditor@master] Always prefer wikitext for action=edit on non-SET wikis

https://gerrit.wikimedia.org/r/353858

Change 353861 had a related patch set uploaded (by Jforrester; owner: Esanders):
[mediawiki/extensions/VisualEditor@wmf/1.30.0-wmf.1] Fix action=edit links for NWE

https://gerrit.wikimedia.org/r/353861

Change 353858 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Always prefer wikitext for action=edit on non-SET wikis

https://gerrit.wikimedia.org/r/353858

Change 353863 had a related patch set uploaded (by Jforrester; owner: Esanders):
[mediawiki/extensions/VisualEditor@wmf/1.30.0-wmf.1] Always prefer wikitext for action=edit on non-SET wikis

https://gerrit.wikimedia.org/r/353863

Change 353861 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@wmf/1.30.0-wmf.1] Fix action=edit links for NWE

https://gerrit.wikimedia.org/r/353861

Change 353863 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@wmf/1.30.0-wmf.1] Always prefer wikitext for action=edit on non-SET wikis

https://gerrit.wikimedia.org/r/353863

Mentioned in SAL (#wikimedia-operations) [2017-05-15T13:37:23Z] <addshore@tin> Synchronized php-1.30.0-wmf.1/extensions/VisualEditor: SWAT: [[gerrit:353861|#1]] [[gerrit:353863|#2]] T165238 T165238 VisualEditor (duration: 00m 41s)

Mentioned in SAL (#wikimedia-operations) [2017-05-15T13:37:23Z] <addshore@tin> Synchronized php-1.30.0-wmf.1/extensions/VisualEditor: SWAT: [[gerrit:353861|#1]] [[gerrit:353863|#2]] T165238 T165238 VisualEditor (duration: 00m 41s)

Jdforrester-WMF closed this task as Resolved.May 15 2017, 1:38 PM

OK, I think this should now be fixed (but you may need to refresh for a couple of minutes in some edge cases). Sorry for the disruption, everyone.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptMay 15 2017, 1:38 PM