Page MenuHomePhabricator

Set up and package wmfmariadbpy helper scripts so they can easily be deployed to all database server and client hosts
Closed, ResolvedPublic

Description

https://phabricator.wikimedia.org/diffusion/OSMD/ is ready. Upload there the latest version of our db misc scripts.

Also, we need to package what it has already been done and deploy it, even if it is not perfect, it is useful now.

Event Timeline

jcrespo created this task.May 15 2017, 4:50 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 15 2017, 4:50 PM
1978Gage2001 moved this task from Triage to In progress on the DBA board.Dec 11 2017, 9:45 AM
Marostegui moved this task from In progress to Triage on the DBA board.Dec 11 2017, 11:06 AM
jcrespo moved this task from Triage to Meta/Epic on the DBA board.Feb 7 2018, 3:37 PM

Change 619953 had a related patch set uploaded (by Jcrespo; owner: Jcrespo):
[operations/software/wmfmariadbpy@master] mariadb-backups: Move backup scripts to its own directory

https://gerrit.wikimedia.org/r/619953

Change 619958 had a related patch set uploaded (by Jcrespo; owner: Jcrespo):
[operations/software/wmfmariadbpy@master] wmfmariadbpy: Reorganize backup scripts into its own directory

https://gerrit.wikimedia.org/r/619958

Change 619953 abandoned by Jcrespo:
[operations/software/wmfmariadbpy@master] mariadb-backups: Move backup scripts to its own directory

Reason:
done on a different branch

https://gerrit.wikimedia.org/r/619953

Change 619962 had a related patch set uploaded (by Jcrespo; owner: Jcrespo):
[operations/software/wmfmariadbpy@master] mariadb-backups: Reorganize files and update paths

https://gerrit.wikimedia.org/r/619962

Change 620005 had a related patch set uploaded (by Jcrespo; owner: Jcrespo):
[operations/software/wmfmariadbpy@master] wmfbackups: Copy backup-related scripts from puppet to wmfmariadbpy

https://gerrit.wikimedia.org/r/620005

Change 619958 merged by jenkins-bot:
[operations/software/wmfmariadbpy@master] wmfmariadbpy: Reorganize backup scripts into its own directory

https://gerrit.wikimedia.org/r/619958

Change 620005 merged by Jcrespo:
[operations/software/wmfmariadbpy@master] wmfbackups: Copy backup-related scripts from puppet to wmfmariadbpy

https://gerrit.wikimedia.org/r/620005

Change 620291 had a related patch set uploaded (by Jcrespo; owner: Jcrespo):
[operations/software/wmfmariadbpy@master] wmfmariadbpy: Load and provide a method for section to port assignment

https://gerrit.wikimedia.org/r/620291

Change 619962 merged by jenkins-bot:
[operations/software/wmfmariadbpy@master] wmfbackups: Split WMFBackup into its logical components (backup methods)

https://gerrit.wikimedia.org/r/619962

Change 620309 had a related patch set uploaded (by Jcrespo; owner: Jcrespo):
[operations/software/wmfmariadbpy@master] [WIP] Add WMFBackup package creation

https://gerrit.wikimedia.org/r/620309

Change 620312 had a related patch set uploaded (by Jcrespo; owner: Jcrespo):
[operations/puppet@production] [WIP] Change backup hosts into using the package version of scripts

https://gerrit.wikimedia.org/r/620312

Change 620315 had a related patch set uploaded (by Jcrespo; owner: Jcrespo):
[operations/software/wmfmariadbpy@master] backup_mariadb: Use path to find backup_mariadb.py

https://gerrit.wikimedia.org/r/620315

Change 620291 merged by Jcrespo:
[operations/software/wmfmariadbpy@master] wmfmariadbpy: Load and provide a method for section to port assignment

https://gerrit.wikimedia.org/r/620291

Change 623754 had a related patch set uploaded (by Jcrespo; owner: Jcrespo):
[operations/software/wmfbackups@master] backup_mariadb: Use path to find backup_mariadb.py

https://gerrit.wikimedia.org/r/623754

Change 620315 abandoned by Jcrespo:
[operations/software/wmfmariadbpy@master] backup_mariadb: Use path to find backup_mariadb.py

Reason:
duplicate of https://gerrit.wikimedia.org/r/c/operations/software/wmfbackups/ /623754

https://gerrit.wikimedia.org/r/620315

Change 623756 had a related patch set uploaded (by Jcrespo; owner: Jcrespo):
[operations/software/wmfbackups@master] [WIP] Add WMFBackup package creation

https://gerrit.wikimedia.org/r/623756

Change 620309 abandoned by Jcrespo:
[operations/software/wmfmariadbpy@master] [WIP] Add WMFBackup package creation

Reason:
Duplicate of https://gerrit.wikimedia.org/r/c/operations/software/wmfbackups/ /623756

https://gerrit.wikimedia.org/r/620309

Change 623756 merged by Jcrespo:
[operations/software/wmfbackups@master] Add WMFBackup package creation

https://gerrit.wikimedia.org/r/623756

Change 623754 abandoned by Jcrespo:
[operations/software/wmfbackups@master] backup_mariadb: Use path to find backup_mariadb.py

Reason:
backup-mariadb will be called instead on a new patch

https://gerrit.wikimedia.org/r/623754

@Kormat can this be considered done as wmfmariadbpy scripts are being deployed via deb (ie: db-switchover, db-compare etc? (I am not fully aware of the whole situation, so wondering whether the scope of this task is already done or if there are pending things)

Kormat closed this task as Resolved.Oct 14 2020, 8:17 AM
Kormat claimed this task.

@Marostegui: good point! Resolving.

Change 620312 abandoned by Jcrespo:
[operations/puppet@production] [WIP] Change backup hosts into using the package version of scripts

Reason:

https://gerrit.wikimedia.org/r/620312