Wikimedia Hackathon 2017: Opening
Closed, ResolvedPublic

Description

Notes from the opening and the open mic are in a comment below!

This task will be updated with details about the Wikimedia Hackathon 2017 Opening session once we have a schedule.

For now hackathon participants should come prepared to make a 1 min or less pitch about their project, session, idea or ask for the help that they need at the event. Most of the opening will be allocated to participants with the microphone.

Currently the opening is scheduled from 10 - 11:30 am on Friday the 19th in room Room Heuriger

Rfarrand created this task.May 15 2017, 6:11 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 15 2017, 6:11 PM

Notes from the Hackathon Opening:
Detailed notes from the opening at bottom.
There is be a video recording of the open-mic by Andrew. link: https://youtu.be/IbgCPW5DtLs

We will hold a second open-mic without video recording at the very end for those who don't want to be on camera

Open Mic

  • Amire80 - edit directly from telegram or facebook messenger (and has candies)
  • Siebrand - If you use Strava (for running and cycling) Join us: https://strava.com/clubs/wikimedia
  • Lucie & Marius - ArticlePlaceholder - using Wikidata to generate Wikipedia placeholder articles - NEEDS design help
  • Birgit Muller - New and Experienced developers how to become BFFs forever
  • Max S. - AutoWikiBrowser - re-writing as web app. Interested? Come join me!
  • Jon Robson - offline experience; progressive web apps, ReactJS experience helpful, trendline API, UI regressions;
  • Peter - FIrst hackathon. Open Knowledge Maps - improve the discovery of research findings for folks outside academia
  • Markus Glaser - Fantastic MediaWiki track (3rd party usage), tomorrow there is a session on how to write BlueSpice extensions, introduction session on Sunday on MediaWiki development for beginners [by whom?]
  • Dmitry - WP Android app; mobile development; offline experience on mobile
  • Robert - signus anon (???) LDAP authentication
  • Jens Ohlig - documentation sprints for any technical project, including Wikidata. Workshops on: translation extension; using phabricator; illustrations and screenshots. Drop-ins welcome.
  • Jonas Kress - WDQS (Wikidata query service) UI, working on things like: code-completion and visualizations
  • Lydia Pintscher - Wikidata ideas: games, data analysis, automaticaly adding references etc. Test how to edit WD from WP
  • Léa Lacroix - First hackathon - Ladies that FLOSS, session about tech event organizors (WIkidataCON this autumn), Breton dances
  • Bryan Davis (bd808) - Cloud Services - labs and tool labs. Session 11am Saturday. Talk to us about anything related.
  • Aaron Halfaker & Amir/Ladsgroup - ORES, prediction scoring - anything AI and machine learning - getting ORES for your wiki (wikimedia and 3rd party) "who wants some ores?" Session Saturday at 2pm. Help us build lists of curse words in your language.
  • Maarten - anything Wikidata realted - SPARQL workshop tomorrow
  • Andre Costa - Wiki loves Monuments - structured data and import of data - Also [[m:wikispeech]]
  • Christoph Jauera (Fisch) - WMDE TechWishes, like RevisionSlider and some smaller open tasks
  • Thomas Arrow - WikiFactMine - Minig facts from papers and linking them to Wikidata items, interested in finding folks to help
  • Base - Bot master- looking for help - CE Spring article contest - wants to collect statistics, collection of antipatterns [?], want to create a tool to identify disambiguation pages, tool to categorize WLM pages
  • Nirzar - Design team at the Foundation is here, if you need help aroudn workflows, research - get in touch. Project around the reading experience with progressive web
  • Thiemo Mättig - Wikidata
  • Tim (kolossos) - maps, geodata, OSM,
  • John L & Josephine - Commons App (Prague prehackathon), looking for Design, UI improvements, testing, bug fixes
  • Henrique Andrade - help to build tools for the Portugese communites
  • Srishti - For the newcomers, there's a session at 3pm to give an overview of the technical spaces in the Wikimedia movment. There will also be some tasks selected for new contributors. Also an overview of Phabricator
  • Sandra (spinster) - "I have a lot of impostor syndrom because I'm not a coder" - power-editor, willing to give feedback on workflows and interaction with GLAM organizations (data-import for them and communication with them)
  • Finn Arup Nielson (Denmark) - SPARQL, javascript,
  • Johan & Paula - Mapbox, based on OpenStreetmaps, looking to find out more about translation, localization, and geohacking
  • Lea Voget - WMDE Wishlist - taskforce about Revisionslider and accessability. Diff agents (Wikidiff2), Moving files to commons from Wikipedias (with history)
  • Volker Eckl - Design team - ask me about usability and accessibility, and design style guide, and OOjs UI.
  • Andre Klapper - phabricator co-maintainer, ask me anything about that. Ask me about suggested tasks, or people to contact.
  • Vera - Make it easier to transfer images with a free license from Flickr to commons - Help needed! - https://commons.wikimedia.org/wiki/Category:Commons_Flickr_resources
  • ???? - session about FlaggedRevisions this evening at 19:00 -
  • Sergeï (putnik)- wikidata in infoboxes, if you want help, ask me!
  • Maxime - https://inventaire.io - web app using wikidata to do book inventory, and vice versa. Wants help with book editions and other inventaire improvements/feedback. Blazegraph.
  • Thomas (TPT) - Wikisource, Wikidata, SPARQL, creating SQL queries from SPARQL to query Wikipedia info (revisons, category data, and so on)
  • Benoit (trizek) - If you want to know more about a project and community, how to work with them - there's a session about creating a central gadget taskforce. how to create gadgets across projects
  • Ziko - Will be in documentation area. interested in wiktheory - 14:00 forum about wikis and research and support, from social scientist approach
  • Gergo (Tgr) - developer wishlist - https://www.mediawiki.org/wiki/Developer_wishlist - ask me about how you can help
  • Dan (Milimetric) - analytics team - rebuilding wikistats, if you want to see the protoype or want to see certian stats, let me know
  • EBernhardson - works with search. Will be replacing query parsing in advanced search functionality. Ask me anything related.
  • T Shrinivasan - python wikitools,
  • Daniel Mietschen - open access signial processing project - bringing open access data into wikidata/wikipedia

Last notes

  • Snacks close to the CAfé are for us
  • Some visas haven't been accepted (two from Cameroon?), it is sad and those people may participate remotely.
  • Take care of people who don't want to be taken in photo.

Happy hacking!!

DETAILED OPENING SESSION NOTES

Claudia: A quick welcome and thanks - Claudia

Demographics

  • 260 participants, 48 nationalities, 21% female
  • Claudia mention the journey to create this event, starting when she has been hired by the Austrian Chapter. Th echapter has grown since.

Thanks

  • silver bullion [[Maria-Theresien-Taller]]
  • Still in use in some parts of the world - you can have a nice diner somevhere if you have one of those 18th century coins
  • WMAT is a member of CEE group, which has also hosted some pre-hackathon in various places (Prague, Thessaloniki, Bucarest, Budapest) since last year. Two co-organizers get a coin.
  • Thanks to the scholarship comitee - Siebrand, Birgit, Jean-Fred, [missing one name]
  • Thanks to Srishti and Rachel for preperations for the hackathon
  • Thanks to two more friends from Germany, Marcus and Richard Heigl
  • Thank you to our sponsors

Introduction to the mentoring program by Sonjia

  • A more guided approach to newcomers
    • A mentor will take care of a newcomer over the week end, to help on integration
    • round of applauses to the mentors!
    • A special session to meet mentors and newcomers will happen after the introduction in the Wiaschtl room

Party !! by Sonja

Karaoke tonight
Party with DJs tomorrow evening - all participants have a voucher to have one free dring on the house

Volunteers role by Rachel

Hackathons are events builted by participants
There is some roles this year for people who want to get involved:

  • Photographers
    • Don't forget the group photo
    • Don't forget that white lanyards mean people don't want to be photographed
  • Event Blogging, see with Srishti
  • Social hosts
    • Introducing newcomers to people
  • Note takers and Phabricators updaters
  • Post-event and notes checking
    • sign up at the registration desk
    • it can be an email reminder in 6 months or a Telegram group, whatever you need

Skill Share

Add a skill you would like to share, or request a skill you would like to devleop on the skill share board in the atrium
You need a skill, please ask Skill share

Finding projects / documentation

  • The open mic is open to anyone at the end of this presentation to introduce to people what you want to work on or find help
    • Anyone can schedule a session about a particular topic, to have input or think in common. See the wiki and edit it
  • The Phabricator board has a lot of open tasks if you want to find something to work on.
  • Describe on the whiteboard sign at your table what you are working on.
  • Showcase at the end of the hackathon, to celebrate what has been done, to present what are the next steps

Logistics, by Claudia

  • Introducing bathrooms, including neutral gender ones above the Café.
  • The quiet space is between the Vienna Café and the bathroom
  • Green Tshirts, has them if you need something
  • Stickers to customize your badge!
  • irc channel in #wmhack, also the Twitter hashtag
  • Telegram group: https://t.me/wmhack
  • The first the wikimedia event to have specific badges for plushies [applauses]

Feedback

  • At the end of the event, you will have a feedback form. It will help to organize better events and improve integration for our friends for next year hackathon [that we are not allowed to mention the name]

Safe space Policy, by Nick

  • "Be excellent to each other" - Nick lists some forbidden things
  • If there is any unappropriate behavor, please contact the committee
  • reminders are displayed in every room
  • People who can be contacted directly about FSP issues stand up in the room - Sonja, Claudia, Rachel, Raimund, Annemarie, Nick.
  • An email adress is also on the reminders

Rachel mentions the Code of conduct

Rfarrand updated the task description. (Show Details)May 19 2017, 10:53 AM
Rfarrand closed this task as Resolved.May 20 2017, 9:22 AM
Aklapper renamed this task from Wikimeda Hackathon 2017: Opening to Wikimedia Hackathon 2017: Opening .May 20 2017, 9:45 AM
Qgil awarded a token.May 22 2017, 10:26 AM