SmashPig has been working with the normalized-for-queue key names, i.e. first_name instead of fname, gross instead of amount. Now that we want to use SmashPig for frontend logic as well, we shouldn't pollute it with the DonationInterface variants.
We've done this with zip->postal_code, and we can do it again.
This will also be a great reduction in confusion.
Note: we will also want to update the log parsing in the audit code to look for the correct keys.