Page MenuHomePhabricator

Upload Wizard and Flickr don't seem to work for mass uploads on Commons
Closed, ResolvedPublic

Description

Win 7, Google Chrome (all updates applied) same behavior using Win 7 and Firefox.

Attempting upload of up to 50 images from Flickr using the assistant for uploading. Out of 50 files only 3 or 4 will survive the trip from being selected to the edit page. Also the part of the form where users can copy categories, descriptions, etc. is missing. See screenshot.

Uncaught TypeError: Cannot read property 'toggle' of undefined

at mw.UploadWizardDetails.useCustomDeedChooser (load.php?debug=false&lang=de&modules=ext.uploadWizard&skin=vector&version=0arq8yq:113)
at MWUploadWizardUpload.eval (eval at <anonymous> (/w/load.php?debug=false&lang=de&modules=jquery%2Cmediawiki%7Cmediawiki.legacy.wikibits&only=scripts&skin=vector&version=0r0nkm9:4), <anonymous>:336:726)
at Function.each (/w/load.php?debug=false&lang=de&modules=jquery%2Cmediawiki%7Cmediawiki.legacy.wikibits&only=scripts&skin=vector&version=0r0nkm9:5)
at UWControllerDetails.uw.controller.Details.load (eval at <anonymous> (/w/load.php?debug=false&lang=de&modules=jquery%2Cmediawiki%7Cmediawiki.legacy.wikibits&only=scripts&skin=vector&version=0r0nkm9:4), <anonymous>:336:477)
at UWControllerDeed.uw.controller.Step.moveNext (eval at <anonymous> (/w/load.php?debug=false&lang=de&modules=jquery%2Cmediawiki%7Cmediawiki.legacy.wikibits&only=scripts&skin=vector&version=0r0nkm9:4), <anonymous>:294:734)
at UWControllerDeed.uw.controller.Deed.moveNext (eval at <anonymous> (/w/load.php?debug=false&lang=de&modules=jquery%2Cmediawiki%7Cmediawiki.legacy.wikibits&only=scripts&skin=vector&version=0r0nkm9:4), <anonymous>:320:2738)
at UWControllerDeed.uw.controller.Deed.load (eval at <anonymous> (/w/load.php?debug=false&lang=de&modules=jquery%2Cmediawiki%7Cmediawiki.legacy.wikibits&only=scripts&skin=vector&version=0r0nkm9:4), <anonymous>:321:276)
at UWControllerUpload.uw.controller.Step.moveNext (eval at <anonymous> (/w/load.php?debug=false&lang=de&modules=jquery%2Cmediawiki%7Cmediawiki.legacy.wikibits&only=scripts&skin=vector&version=0r0nkm9:4), <anonymous>:294:734)
at UWControllerUpload.uw.controller.Upload.moveNext (eval at <anonymous> (/w/load.php?debug=false&lang=de&modules=jquery%2Cmediawiki%7Cmediawiki.legacy.wikibits&only=scripts&skin=vector&version=0r0nkm9:4), <anonymous>:360:536)
at eval (eval at <anonymous> (/w/load.php?debug=false&lang=de&modules=jquery%2Cmediawiki%7Cmediawiki.legacy.wikibits&only=scripts&skin=vector&version=0r0nkm9:4), <anonymous>:293:624)

/w/api.php?action=query&format=json&titles=File%3A03+00437%2Ejpg&prop=info%7Cimageinfo&inprop=protection&iiprop=url%7Cmime%7Csize&iiurlwidth=150 Failed to load resource: net::ERR_NAME_NOT_RESOLVED
/w/api.php?action=query&format=json&generator=allpages&gapnamespace=6&gappr…info%7Cimageinfo&inprop=protection&iiprop=url%7Cmime%7Csize&iiurlwidth=150 Failed to load resource: net::ERR_NAME_NOT_RESOLVED

Event Timeline

HiW created this task.May 21 2017, 1:38 AM
Restricted Application added a project: Multimedia. · View Herald TranscriptMay 21 2017, 1:38 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Change 355201 had a related patch set uploaded (by Matthias Mullie; owner: Matthias Mullie):
[mediawiki/extensions/UploadWizard@master] Don't use property before it's defined

https://gerrit.wikimedia.org/r/355201

@HiW: I've submitted a patch that'll fix the TypeError you pasted (and will also fix the missing "copy" widget)
I'm not entirely certain that the lack of surviving uploads is related and I was unable to reproduce this - can you post a link to the Flickr library you were trying to import?

HiW added a comment.May 23 2017, 12:50 PM

@matthiasmullie :

The toggle error is still there. Hope the patch will be applied soon.

at line 113: uncaught TypeError. Cannot read property 'toggle' of undefined

I still can't upload a bigger batch. I tried several Flickr libraries, hoping a name or filename might trigger the problem. No effect. The latest library I tried was: https://www.flickr.com/photos/cantanima/albums/72157655688156259 but you can use any other, same problem.

Caught this one as well:

Internal Server Error

Fetching thumbnail failed: Array
(
[0] => Array
(
[0] => http-timed-out
[1] => https://upload.wikimedia.org/wikipedia/commons/thumb/temp/5/59/20170523124120%21URLe39b8596c49e.urlupload_./75px-20170523124120%21URLe39b8596c49e.urlupload_..jpeg
)

)

url = https://upload.wikimedia.org/wikipedia/commons/thumb/temp/5/59/20170523124120%21URLe39b8596c49e.urlupload_./75px-20170523124120%21URLe39b8596c49e.urlupload_..jpeg

Unrelated hiccup on my side?

Change 355201 merged by jenkins-bot:
[mediawiki/extensions/UploadWizard@master] Don't use property before it's defined

https://gerrit.wikimedia.org/r/355201

@HiW Matthias wrote the fix (and I just merged it), but it's not deployed on Wikimedia sites yet. It will be deployed per the usual schedule: https://www.mediawiki.org/wiki/MediaWiki_1.30/Roadmap on 23-25 May. (Although maybe we should deploy it sooner in a SWAT window – @Jdforrester-WMF?)

Looks like this will just be part of the regular release schedule. For Commons specifically, the change should be deployed today around 19:00-21:00 UTC, or 4-6 hours from now (https://wikitech.wikimedia.org/wiki/Deployments#deploycal-item-20170524T1900).

matmarex closed this task as Resolved.May 24 2017, 3:09 PM
matmarex removed a project: Patch-For-Review.