CXServer Apertium MT suggestions are empty in Special:Translate
Closed, ResolvedPublic

Description

The response we get is always {"contents":"<div></div>"}. This used to work, so I guess it is either some change in cxserver or in the html library.

Restricted Application added a project: ContentTranslation. · View Herald TranscriptMay 21 2017, 8:58 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Nikerabbit triaged this task as High priority.May 21 2017, 8:59 AM
Nikerabbit added subscribers: Trizek-WMF, Nemo_bis.
Nemo_bis updated the task description. (Show Details)May 21 2017, 8:59 AM

Change 354909 had a related patch set uploaded (by Nikerabbit; owner: Nikerabbit):
[mediawiki/extensions/Translate@master] Fix cxserver service showing only empty suggestions

https://gerrit.wikimedia.org/r/354909

@Nikerabbit Since when this is happening? I can look into cxserver change during that time (Although, no big change since March for sure).

This was first reported on Saturday, but it could have started earlier as well.

Change 354909 merged by jenkins-bot:
[mediawiki/extensions/Translate@master] Fix cxserver service showing only empty suggestions

https://gerrit.wikimedia.org/r/354909

This was first reported on Saturday, but it could have started earlier as well.

Might be the same issue or a separate one, but Xuacu says since several months ago for Asturian:
https://translatewiki.net/wiki/Thread:Support/Apertium_MT_not_working_for_Asturian_language

Oriciu added a subscriber: Oriciu.Thu, May 25, 12:55 PM

Indeed, I noticed it was not working for Asturian in TW some months ago (maybe since January or February), following a major software change in TranslateWiki.
Apertium also stopped working in Wikipedia for a few days, then it was available again.

Apertium also stopped working in Wikipedia for a few days, then it was available again.

Did you mean Apertium in ContentTranslation? If yes, can you please provide more details?

Apertium also stopped working in Wikipedia for a few days, then it was available again.

Did you mean Apertium in ContentTranslation? If yes, can you please provide more details?

Yes, ContentTranslation stopped working for a while, but in was soon available again.
I'm sorry, I can't provide other details because it was fixed quickly an I didn't open a support ticket.

Nikerabbit closed this task as Resolved.Sun, May 28, 9:47 AM

Fix now deployed and confirmed both in WMF and translatewiki.net.