Page MenuHomePhabricator

German Wikipedia's main page shows significantly stale content
Closed, ResolvedPublic1 Story Points

Description

German Android readers are reporting that the main page is showing content for prior days. This appears to be an issue with the RESTBase endpoint: https://de.wikipedia.org/api/rest_v1/page/html/Wikipedia:Hauptseite.

Have we introduced differential caching by namespace somewhere? This has previously caused issues for the dewiki main page, which is under the Wikipedia namespace rather than the main namespace.

See also:
T123272: Main page doesn't get updated
T126979: [Bug] Still loading a stale Main Page with content service enabled
T131554: Android beta app loads an old "Article of the day" (at least for dewiki)

Details

Related Gerrit Patches:
mediawiki/services/parsoid/deploy : masterBump to deploy-2017-05-25

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 22 2017, 3:48 PM
Restricted Application added a project: Product-Infrastructure-Team-Backlog. · View Herald Transcript
Mholloway renamed this task from German Wikipedia's main page stuck on May 15th to German Wikipedia's main page shows old content.May 25 2017, 7:03 PM
Mholloway updated the task description. (Show Details)
Mholloway updated the task description. (Show Details)
Niedzielski renamed this task from German Wikipedia's main page shows old content to German Wikipedia's main page shows significantly stale content.May 25 2017, 7:22 PM
Pchelolo claimed this task.EditedMay 25 2017, 7:32 PM
Pchelolo added a project: Parsoid.
Pchelolo added subscribers: ssastry, Pchelolo.

I've tracked it down to a problem in Parsoid and title validation. Perhaps some weird link or template was included so right now Parsoid is not able to parse this page.

The exception is: https://logstash.wikimedia.org/app/kibana#/doc/logstash-*/logstash-2017.05.25/restbase?id=AVxBJvpxqfND4HJ7OyXb&_g=()

What's worse is that it kills a Parsoid worker

Pchelolo removed Pchelolo as the assignee of this task.May 25 2017, 8:43 PM
Pchelolo edited projects, added Services (watching); removed RESTBase.

Unassigning this from myself since Parsoid is the cause of this.

Please prioritize accordingly, the android app is severely affected by this for Android App users.

Change 355690 had a related patch set uploaded (by Arlolra; owner: Arlolra):
[mediawiki/services/parsoid/deploy@master] Bump to deploy-2017-05-25

https://gerrit.wikimedia.org/r/355690

Change 355690 merged by jenkins-bot:
[mediawiki/services/parsoid/deploy@master] Bump to deploy-2017-05-25

https://gerrit.wikimedia.org/r/355690

Elitre added a subscriber: Elitre.May 25 2017, 9:28 PM

Mentioned in SAL (#wikimedia-operations) [2017-05-25T21:31:03Z] <arlolra> Updated Parsoid to rGPAR5b52d07ba74a (T166068)

Arlolra closed this task as Resolved.May 25 2017, 9:34 PM
Arlolra claimed this task.
mobrovac added a subscriber: mobrovac.

Thank you @Arlolra for the quick resolution!