[Regression wmf.2] "Uncaught TypeError: Cannot read property 'getDocument' of null" appears after adding any citation
Closed, DuplicatePublic1 Story Points

Description

Add any citation (Cite news/Cite web etc.)

In the console, the following error appears:
Uncaught TypeError: Cannot read property 'getDocument' of null

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 24 2017, 12:52 PM
Elitre added a subscriber: Elitre.May 24 2017, 2:31 PM

(FWIW, WFM with citoid here https://test2.wikipedia.org/w/index.php?title=Sandbox&type=revision&diff=317924&oldid=317458 - but I swear I had done that same edits a few seconds before - I was sure I had saved it correctly...)

Yes, that error does not effect adding the citation and saving it correctly. The error appearing in the console is a seemingly harmless regression nonetheless.

(Thanks for the clarification! In T166254 my console screamed at me as well, but the action is also failing there.)

Ryasmeen closed this task as Resolved.May 25 2017, 2:53 PM

Seems like it is fixed in Beta Cluster now,

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptMay 25 2017, 2:53 PM
Jdforrester-WMF set the point value for this task to 1.
Jdforrester-WMF triaged this task as High priority.
Ryasmeen reopened this task as Open.Jun 5 2017, 5:51 PM

Getting this error again on Beta cluster.

Can't reproduce. Which page/browser?

DLynch added a subscriber: DLynch.Jun 5 2017, 11:28 PM

I haven't been able to reproduce this either, Chrome or Firefox. More detailed reproduction steps? (I also don't get that missing/empty |title error you have, also using bbc.co.uk, which may be related.)

I can reproduce this... but only on the specific page that @Ryasmeen linked in her example.

  1. Go to https://en.wikipedia.beta.wmflabs.org/wiki/User:RYasmeen_(WMF)/sandbox?veaction=edit&section=1
  2. Edit page in VE
  3. Click "Cite"
  4. Type "bbc.co.uk" into box and click "Generate"
  5. Reference is shown, click insert

The reference is successfully inserted, but the error is shown in the console.

Deskana lowered the priority of this task from High to Low.Jun 7 2017, 11:15 AM

Since this seems to be specific to a single page, lowering priority.

Ryasmeen added a comment.EditedJun 12 2017, 2:29 PM

Yeah not sure what's special about that page that would cause this. I am being able to consistently reproduce it, even if I blank the whole page and then add citation :(

Oh hey, I think this is T168932 as well. (Same error, at least.)