Page MenuHomePhabricator

Back button not letting me back away from RC Page
Closed, ResolvedPublic

Description

  1. In Mac Chrome, with the RC Page beta enabled, go to the Main page of en.wiki.
  2. Use the left nav to travel to the Recent Changes page.
  3. Hit the browser back button.

Expected result: go back to the Main page.
Actual result: RC Page reloads.

Details

Related Gerrit Patches:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 25 2017, 9:13 PM

Change 355846 had a related patch set uploaded (by Mooeypoo; owner: Mooeypoo):
[mediawiki/core@master] [wip] RCFilters UI: Compare states instead of params when switching URL

https://gerrit.wikimedia.org/r/355846

Change 355846 merged by jenkins-bot:
[mediawiki/core@master] RCFilters UI: Compare states instead of params when switching URL

https://gerrit.wikimedia.org/r/355846

@Mooeypoo Tested it in beta - every time I click on back browser button on RC page with enabled filters I see type header as XHR. With not enabled RC filters, browsers back/forward buttons work as expected.

It doesn't go back to the previous page for you when you click the back button?

@Mooeypoo It doesn't. I repeated (in different browsers and different users) the exact scenario described in the ticket: the landing page is Main page, then from left navigation go to Recent changes - and then click Back browser button. RC page reloads.

Forward browser button works.

Mooeypoo added a comment.EditedMay 31 2017, 4:33 PM

I can't reproduce this - it works perfectly for me on master and in Beta in Chrome.

Can you verify you're hard-reloading/refreshing ? This is weird...

It worked for me too locally when testing Moriel's change; I'll look again on beta in a bit.

WFM in beta in both Chrome and Firefox

It works! When I was testing previously I got an impression that the fix was not quite "trickled down" yet.

QA Recommendation: Resolve

jmatazzoni closed this task as Resolved.Jun 1 2017, 11:25 PM

Selecting the number of edits or days for the event list at recent changes with this beta feature enabled does not work for me now (Chrome). Can anyone confirm this bug, and could it be caused by this fix?

@Njardarlogar: Works for me on https://en.wiktionary.org/wiki/Special:RecentChanges changing to last 500 entries in Chromium 58. Please check with safemode on and feel free to file a separate task with steps to reproduce by following https://mediawiki.org/wiki/How_to_report_a_bug - thanks.

@Njardarlogar, I'm seeing the bug you mention. I've filed a new ticket for it, T167551