Page MenuHomePhabricator

Inform users about changes in PDF rendering service - create a book page
Closed, ResolvedPublic2 Estimated Story Points

Description

Goal:
Inform users about changes in PDF rendering service on the collections extension (https://en.wikipedia.org/wiki/Special:Book)
This replicates the banner in T165956

Proposal:
Add a banner with relevant information and collect feedback about the change using a call to action

Background: we want to make sure that we're getting the right audience for the conversation around sunsetting OCG and identifying requirements for Electron here: https://www.mediawiki.org/wiki/Reading/Web/PDF_Functionality
We would like to add a banner informing of the change to the create a book page (collections extension)

Text (create a book):
We're having significant problems with the function we currently use to create PDFs. We unfortunately have to replace it. This might affect the styling and feature set of Books. We would like to invite you to a conversation around the functionality necessary in the proposed replacement. For feedback, please visit the project page here: https://www.mediawiki.org/wiki/Reading/Web/PDF_Functionality

Acceptance criteria:

Testing Criteria

  1. Go to https://en.wikipedia.beta.wmflabs.org/wiki/Fox
  2. Select "create a book" from the print/export section
  3. Select "Start Book Creator"
  4. From the book creator menu, add current page to the book
  5. Select "show book"

Expected behavior: Banner should appear on page

Note: shortcut to the banner is at this page: https://en.wikipedia.beta.wmflabs.org/wiki/Special:Book

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 30 2017, 2:53 PM
ovasileva triaged this task as High priority.May 30 2017, 2:54 PM
ovasileva moved this task from Incoming to Upcoming on the Readers-Web-Backlog board.
ovasileva updated the task description. (Show Details)
ovasileva updated the task description. (Show Details)
ovasileva updated the task description. (Show Details)
ovasileva updated the task description. (Show Details)
ovasileva set the point value for this task to 2.
Jdlrobson updated the task description. (Show Details)May 30 2017, 4:25 PM
Jdlrobson removed the point value for this task.
ovasileva updated the task description. (Show Details)May 30 2017, 4:27 PM
Jdlrobson updated the task description. (Show Details)May 30 2017, 4:27 PM
ovasileva set the point value for this task to 2.May 30 2017, 4:27 PM
bmansurov claimed this task.Jun 1 2017, 4:26 PM

Change 356643 had a related patch set uploaded (by Bmansurov; owner: Bmansurov):
[mediawiki/extensions/Collection@master] Add warning message to Special:Book

https://gerrit.wikimedia.org/r/356643

Minor fix needed then this looks good to go!

bmansurov removed bmansurov as the assignee of this task.Jun 5 2017, 4:50 PM
bmansurov added a subscriber: bmansurov.

Change 356643 merged by jenkins-bot:
[mediawiki/extensions/Collection@master] Add warning message to Special:Book

https://gerrit.wikimedia.org/r/356643

phuedx assigned this task to ABorbaWMF.Jun 6 2017, 10:30 AM
phuedx added a subscriber: phuedx.

@ovasileva, @Jdlrobson: Can this be tested on the Beta Cluster?

@ovasileva, @Jdlrobson: Can this be tested on the Beta Cluster?

Nothing to see here…

@phuedx, @ABorbaWMF - it shows once the book creator is launched, adding testing criteria in the task description

ovasileva updated the task description. (Show Details)Jun 6 2017, 10:47 AM
pmiazga added a subscriber: pmiazga.Jun 6 2017, 1:20 PM

Tested locally, looks ok{F8390681}

I got the banner to appear once when I first tried it. I then closed the banner. Since then no amount of purging caches and deleting cookies have seen its return. Now when I select 'create a book,' the 'book creator' page appears.

I ran into a lot of problems in general with the feature.
Some notes:

  • Once closed the banner does not reappear and there is no onscreen link or widget for it (that I can find)
  • Once book creator is started, it interferes with page previews. In some cases, the reader popup obscures the page preview. In other cases, the page preview does not appear at all
  • On the 'manage your book' page
    • There is no save button after changes are made.
    • I created a chapter, but I cannot add to it.
    • Downloading ended with renderer failed (3/3 times I tried)
    • Pedia Press Preview seemed to work
  • Selecting 'disable creator,' does not result in the appearance of 'enable creator.' Selecting 'disable creator' again reopens the disable confirmation page.
  • There are no links to book creator or widgets to enable/disable book creator in these locations: Within an article (once enabled and disabled). On a side menu. Within preferences
  • Disabling 'book creator' should no abandon the book (I think). I imagine users with want to turn it on/off as needed, especially when creating large volumes.

@ovasileva Let me know what you think.

@ABorbaWMF - we're testing the warning box, not the whole book banner.

Chatted with @pmiazga, banners are appearing.

ovasileva closed this task as Resolved.Jun 7 2017, 10:18 AM

Thank you @ABorbaWMF, this task is all done. I'll review the other book rendering issues seperately.