Page MenuHomePhabricator

HTMLSelectOrOtherField - no toggle with default option
Closed, ResolvedPublic

Description

The text field of HTMLSelectOrOtherField is hiding when selecting a value that is not 'other', but it is not hiding when such a value is set by 'default'.

This issue may be observed in the page Special:Block, when a default value (e.g. "1 month") is set in MediaWiki:ipb-default-expiry.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 30 2017, 9:11 PM

Change 357910 had a related patch set uploaded (by Louperivois; owner: Louperivois):
[mediawiki/core@master] Bug: T166621 : HTMLSelectOrOtherField - no toggle with default option - https://phabricator.wikimedia.org/T166621

https://gerrit.wikimedia.org/r/357910

Change 357910 had a related patch set uploaded (by Louperivois; owner: Louperivois):
[mediawiki/core@master] HTMLSelectOrOtherField - no toggle with default option

https://gerrit.wikimedia.org/r/357910

The bug was caused by a refactor three years ago in https://gerrit.wikimedia.org/r/#/c/133254/.

Change 357910 merged by jenkins-bot:
[mediawiki/core@master] mw.htmlform: Fix hiding of the textbox for 'selectorother' fields on page load

https://gerrit.wikimedia.org/r/357910

matmarex closed this task as Resolved.Jul 31 2017, 1:49 PM
matmarex assigned this task to Louperivois.
matmarex removed a project: Patch-For-Review.