Page MenuHomePhabricator

Linter extension stopped updating errors in sida/page-namespace (104) 2017-05-15
Closed, ResolvedPublic

Description

The linter-extension stopped uppdating errors in sida/page-namespace (104) and possibly index-namespace (108) in the evening 15 May 2017 on Swedish Wikisource. No new errors are added and fixed errors are not removed.

To reproduce:
Go to obsolete tags-page on Swedish Wikisource:
https://sv.wikisource.org/w/index.php?title=Special:LintErrors/obsolete-tag&dir=prev&namespace=104
the last entry there:
https://sv.wikisource.org/w/index.php?title=Sida:%C3%96stg%C3%B6tars_minne.djvu/36&action=history
was added 15 May 2017 and should have been removed the 31 May.

Event Timeline

Thurs created this task.May 31 2017, 11:41 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 31 2017, 11:41 AM
Legoktm added a subscriber: Legoktm.

This is probably because Parsoid now only reports lint errors for wikitext content models. Since proofreadpage's content models are wikitext based we should probably whitelist them.

Change 356409 had a related patch set uploaded (by Subramanya Sastry; owner: Subramanya Sastry):
[mediawiki/services/parsoid@master] T166655: Use generalized concept of lintable content models

https://gerrit.wikimedia.org/r/356409

Change 356409 merged by jenkins-bot:
[mediawiki/services/parsoid@master] T166655: Use generalized concept of lintable content models

https://gerrit.wikimedia.org/r/356409

Mentioned in SAL (#wikimedia-operations) [2017-06-05T20:16:45Z] <subbu> updated parsoid to 141fc07d (T166655)

ssastry closed this task as Resolved.Jun 5 2017, 9:51 PM
ssastry claimed this task.
ssastry triaged this task as Medium priority.
ssastry removed a project: Patch-For-Review.