Page MenuHomePhabricator

Possible conflict with other extensions
Closed, ResolvedPublic

Description

Upon trying to edit any page I keep getting:

...
[session] User::loadFromSession called before the end of Setup.php
#0 /var/www/includes/user/User.php(5125): User->load()
#1 /var/www/includes/user/User.php(2768): User->loadOptions()
#2 /var/www/includes/context/RequestContext.php(364): User->getOption(string)
#3 /var/www/includes/Message.php(364): RequestContext->getLanguage()
#4 /var/www/includes/Message.php(1188): Message->getLanguage()
#5 /var/www/includes/Message.php(802): Message->fetchMessage()
#6 /var/www/includes/Message.php(902): Message->toString()
#7 /var/www/extensions/Lingo/src/Lingo.php(74): Message->text()
#8 /var/www/includes/Setup.php(850): Lingo\Lingo::Lingo\{closure}()
#9 /var/www/includes/WebStart.php(137): require_once(string)
#10 /var/www/api.php(38): require(string)
#11 {main}
[session] User::loadFromSession called before the end of Setup.php
#0 /var/www/includes/user/User.php(2089): User->load()
#1 /var/www/includes/user/User.php(5133): User->getId()
#2 /var/www/includes/user/User.php(2768): User->loadOptions()
#3 /var/www/includes/context/RequestContext.php(364): User->getOption(string)
#4 /var/www/includes/Message.php(364): RequestContext->getLanguage()
#5 /var/www/includes/Message.php(1188): Message->getLanguage()
#6 /var/www/includes/Message.php(802): Message->fetchMessage()
#7 /var/www/includes/Message.php(902): Message->toString()
#8 /var/www/extensions/Lingo/src/Lingo.php(74): Message->text()
#9 /var/www/includes/Setup.php(850): Lingo\Lingo::Lingo\{closure}()
#10 /var/www/includes/WebStart.php(137): require_once(string)
#11 /var/www/api.php(38): require(string)
#12 {main}
[session] User::loadFromSession called before the end of Setup.php
#0 /var/www/includes/user/User.php(2089): User->load()
#1 /var/www/includes/user/User.php(3381): User->getId()
#2 /var/www/includes/user/User.php(3389): User->isLoggedIn()
#3 /var/www/extensions/UniversalLanguageSelector/UniversalLanguageSelector.hooks.php(243): User->isAnon()
#4 /var/www/includes/Hooks.php(195): UniversalLanguageSelectorHooks::getLanguage(User, string, RequestContext)
#5 /var/www/includes/context/RequestContext.php(368): Hooks::run(string, array)
#6 /var/www/includes/Message.php(364): RequestContext->getLanguage()
#7 /var/www/includes/Message.php(1188): Message->getLanguage()
#8 /var/www/includes/Message.php(802): Message->fetchMessage()
#9 /var/www/includes/Message.php(902): Message->toString()
#10 /var/www/extensions/Lingo/src/Lingo.php(74): Message->text()
#11 /var/www/includes/Setup.php(850): Lingo\Lingo::Lingo\{closure}()
#12 /var/www/includes/WebStart.php(137): require_once(string)
#13 /var/www/api.php(38): require(string)
#14 {main}
Fully initialised
...

Event Timeline

Calexit created this task.Jun 1 2017, 4:32 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 1 2017, 4:32 PM

@Calexit: Possible conflict of what with other extensions? MediaWiki-extensions-Lingo? :) Which versions is this about?
Please see https://mediawiki.org/wiki/How_to_report_a_bug

MW 1.28.2
I see UniversalLanguageSelector in the stacktrace which I do have. I also have VE on which I saw in another task reported to cause issues.

Foxtrott closed this task as Resolved.Jun 2 2017, 8:14 AM
Foxtrott claimed this task.
Foxtrott added a subscriber: Foxtrott.

That's a problem in Lingo that should be fixed in the latest version. Please update.
If the problem remains, please re-open.

Framawiki added a project: MediaWiki-General-or-Unknown.

@Framawiki: Please don't add an unrelated project (MediaWiki core) when the task is about extensions only. Thanks!