Page MenuHomePhabricator

[Regression pre-wmf.4] Vector's personal tools are appearing above OOjs UI's global overlay ... again
Closed, ResolvedPublic1 Story Points

Description

It looks like Vector/skinStyles/ooui.less isn't getting loaded, maybe a change in ResourceLoader?

Event Timeline

Esanders created this task.Jun 5 2017, 4:39 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 5 2017, 4:39 PM
Esanders triaged this task as High priority.Jun 5 2017, 4:39 PM
matmarex claimed this task.Jun 5 2017, 4:46 PM
Jdforrester-WMF renamed this task from Personal tools appearing above global overlay ... again to [Regression pre-wmf.4] Vector's personal tools are appearing above OOjs UI's global overlay ... again.Jun 5 2017, 5:02 PM
Jdforrester-WMF set the point value for this task to 1.

Change 357241 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/core@master] Restore the ability to set $wgResourceModuleSkinStyles for 'oojs-ui-core.styles'

https://gerrit.wikimedia.org/r/357241

Change 357241 merged by jenkins-bot:
[mediawiki/core@master] Restore the ability to set $wgResourceModuleSkinStyles for 'oojs-ui-core.styles'

https://gerrit.wikimedia.org/r/357241

Jdforrester-WMF added a subscriber: Jdforrester-WMF.

Not fixed in master or wmf.4 yet.

kaldari added a subscriber: kaldari.Jun 6 2017, 9:30 PM

There also seems to be a module loading issue at T167216, maybe related.

greg added a subscriber: greg.Jun 6 2017, 9:51 PM

This is definitely resolved for the specific case, but apparently somehow all $wgResourceModuleSkinStyles customizations are broken for Vector, see T167216.

mmodell closed this task as Resolved.Jun 7 2017, 8:39 PM
Restricted Application added a project: Performance-Team. · View Herald TranscriptMar 22 2018, 5:41 AM