Page MenuHomePhabricator

Unexpected general module "mediawiki.widgets.DateInputWidget" in styles queue.
Closed, ResolvedPublic

Description

See T92459: ResourceLoader should restrict addModuleStyles() to modules that only provide styles

Seen on https://logstash.wikimedia.org/goto/6a23ca1975a524a20e452b2b57e839c3 when hiding the warnings from Proodreadpage and Math.

Only on test/test2, so I'm assuming this is a wmf.4 regression.

Event Timeline

Change 357668 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/core@master] Split off styles for PHP DateInputWidget to separate module

https://gerrit.wikimedia.org/r/357668

mmodell added a subscriber: mmodell.Jun 7 2017, 8:20 PM

I'm seeing 545,624 instances of this warning (Unexpected general module "{module}" in styles queue.) in the past hour alone. Are they mostly unrelated to this or this is the cause of most/all of them?

Change 357694 had a related patch set uploaded (by 20after4; owner: Bartosz Dziewoński):
[mediawiki/core@wmf/1.30.0-wmf.4] Split off styles for PHP DateInputWidget to separate module

https://gerrit.wikimedia.org/r/357694

Change 357668 merged by jenkins-bot:
[mediawiki/core@master] Split off styles for PHP DateInputWidget to separate module

https://gerrit.wikimedia.org/r/357668

Jdforrester-WMF closed this task as Resolved.Jun 7 2017, 8:57 PM

Change 357694 merged by jenkins-bot:
[mediawiki/core@wmf/1.30.0-wmf.4] Split off styles for PHP DateInputWidget to separate module

https://gerrit.wikimedia.org/r/357694

I'm seeing 545,624 instances of this warning (Unexpected general module "{module}" in styles queue.) in the past hour alone. Are they mostly unrelated to this or this is the cause of most/all of them?

Most of them are T158376: Unexpected general module 'ext.math.scripts' in styles queue. (fixed in wmf.4) and T167353: Unexpected general module "ext.proofreadpage.page" in styles queue. (not yet fixed, just filed by me).

Mentioned in SAL (#wikimedia-operations) [2017-06-07T21:23:34Z] <twentyafterfour@tin> Synchronized php-1.30.0-wmf.4/: sync 3248a17f5529ab6d5cbabb75dd0e72a7589f8633 refs T167343 (duration: 07m 52s)

Volker_E moved this task from Backlog to Waiting for breaking release on the OOUI board.
Volker_E removed a subscriber: gerritbot.