Page MenuHomePhabricator

Regression: Main menu unstyled without JS.
Closed, ResolvedPublic

Description

The module skins.minerva.mainMenu.styles is no longer being added to the page as a stylesheet.
The module skins.minerva.mainMenu.icons is also added via JS.

Expected:

  • Styles should be loaded via addModuleStyles inside onSpecialPageBeforeExecute

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 8 2017, 12:25 AM
Jdlrobson renamed this task from Main menu unstyled without JS. to Regression: Main menu unstyled without JS..Jun 8 2017, 12:25 AM
ovasileva triaged this task as High priority.Jun 8 2017, 12:06 PM
phuedx added a subscriber: phuedx.Jun 8 2017, 1:12 PM

This regression was introduced in rEMFRa7a3311bdf31: MainMenu belongs to Minerva not MobileFrontend, which will be riding the train when it resumes.

Change 357830 had a related patch set uploaded (by Bmansurov; owner: Bmansurov):
[mediawiki/extensions/MobileFrontend@master] Add styles to Special:MobileMenu

https://gerrit.wikimedia.org/r/357830

bmansurov removed bmansurov as the assignee of this task.Jun 8 2017, 3:59 PM
bmansurov added a subscriber: bmansurov.

Change 357830 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Add styles to Special:MobileMenu

https://gerrit.wikimedia.org/r/357830

Change 357846 had a related patch set uploaded (by Jdlrobson; owner: Bmansurov):
[mediawiki/extensions/MobileFrontend@wmf/1.30.0-wmf.4] Add styles to Special:MobileMenu

https://gerrit.wikimedia.org/r/357846

Since this impacts all grade C browsers and I'm SWATing anyway, I will get this deployed today at 4pm PST.

phuedx added a comment.Jun 8 2017, 5:17 PM

Agreed. It'll roll out to group1 wikis during today's MediaWiki train deployment.

Change 357846 merged by MaxSem:
[mediawiki/extensions/MobileFrontend@wmf/1.30.0-wmf.4] Add styles to Special:MobileMenu

https://gerrit.wikimedia.org/r/357846

Jdlrobson closed this task as Resolved.Jun 8 2017, 7:01 PM
Jdlrobson claimed this task.