Page MenuHomePhabricator

Refactor HTML templates
Closed, ResolvedPublic

Description

Cf. https://github.com/Wikidata/primarysources/blob/master/frontend/freebase2wikidata.js#L79

We need to update the current html template to reflect the wikidata UI changes that occurred since the last update.

Event Timeline

Hjfocs created this task.Jun 19 2017, 9:53 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 19 2017, 9:53 AM
Hjfocs moved this task from To do to Done on the Wikidata-primary-sources board.Jul 4 2017, 1:23 PM
Hjfocs closed this task as Resolved.Jul 4 2017, 1:44 PM
Hjfocs claimed this task.

duplicate of T168247

Kiailandi reopened this task as Open.Aug 3 2017, 1:30 PM
Kiailandi claimed this task.
Kiailandi triaged this task as Unbreak Now! priority.
Kiailandi updated the task description. (Show Details)

duplicate of T168247

Considering what we discovered about the template system and the path we chose to follow I have re-opened the task as the refactoring process is not trivial.

Kiailandi moved this task from Done to Doing on the Wikidata-primary-sources board.Aug 3 2017, 1:34 PM
Kiailandi added a comment.EditedAug 4 2017, 2:01 PM

While refactoring the template I've noticed that the valueview div used as a wrapper for our objects is not used in other "vanilla" wikidata pages.

'<div class="valueview valueview-instaticmode" aria-disabled="false">' +
    '{{qualifier-object}}' +
'</div>' +

Source: Primary Sources tool on Github

As far as I was able to understand the valueview class comes from the ValueView extension but I've not been able to understand how it is supposed to work for our objects or its purpose in the current template.

Because of this I will remove it in the new version of the template and eventually add it when replacing the {{qualifier-object}} placeholder via javascript using the jQuery function instead of injecting plain text in the generated html template.

Kiailandi lowered the priority of this task from Unbreak Now! to High.Aug 7 2017, 4:03 PM
Lydia_Pintscher moved this task from incoming to monitoring on the Wikidata board.Dec 22 2017, 4:53 PM
Hjfocs closed this task as Resolved.May 31 2018, 9:02 AM