Problems clicking slider lines and browsing with arrows on Chrome RTL
Closed, ResolvedPublic

Description

When clicking slider lines in Chrome in RTL the pointers move to the wrong position. Also browsing with the arrows seems to be broken there and is not really working.

This only seems to happen when the slider shows a part of the history where you can load more revisions to the left and right. See example link:

https://he.wikipedia.org/w/index.php?diff=16274909&oldid=8333872&title=עמוד_ראשי&type=revision

The bug seems to be related to wrong position numbers on the revisions. They seem to break when new revisions are loaded in the initial load to fill the screen. This also affects the grayed revision bars that mark the range of the selection. As seen in the screenshot there is an offset between the pointer positions and the grayed revisions. When the browser window is resized and the slider renders fresh, the positioning is fixed.

A rough backtracing of the bug revealed, that it already occurs long before we introduced the new sliding mechanism - so it seems no one noticed so far. (?)

Broken in all Chrome V8 engine browsers

  • Chromium
  • Vivaldi
  • Opera

Works in

  • Firefox
  • IE
  • Safari
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 19 2017, 1:55 PM
WMDE-Fisch triaged this task as Unbreak Now! priority.Jun 19 2017, 2:04 PM
WMDE-Fisch moved this task from Proposed to Sprint ready on the WMDE-QWERTY-Team-Board board.
Restricted Application added subscribers: Jay8g, TerraCodes. · View Herald TranscriptJun 19 2017, 2:04 PM
Tobi_WMDE_SW moved this task from Incoming to Doing on the Revision-Slider board.

Very strange bug. Also seems only to occur when scrolled a few pages with the arrows and fixes when the page is redrawn ( e.g. due to resizing )

WMDE-Fisch updated the task description. (Show Details)Jun 20 2017, 1:13 PM
WMDE-Fisch lowered the priority of this task from Unbreak Now! to High.Jun 20 2017, 1:50 PM
WMDE-Fisch renamed this task from Problems clicking slider lines on Chrome RTL to Problems clicking slider lines and browsing with arrows on Chrome RTL.Jun 21 2017, 11:08 AM
WMDE-Fisch updated the task description. (Show Details)

After a full day debugging and the feeling that this is a bug in all parts of the RevisonSlider. I tested the issue with different versions of Chrome on SauceLabs. It seems the issue got introduced with Chrome 58 and is still present in the current Chrome 59. Using Chrome dev and beta on SauceLabs the issue is fixed and everything works as before.

The fact that the issue seems tight to the newer Chrome versions would also explain why we had no complains so far. So my rough plan here would be to wait for Chrome 60 and hope that the issue is fixed.

WMDE-Fisch updated the task description. (Show Details)Jun 21 2017, 11:21 AM

Change 360647 had a related patch set uploaded (by WMDE-Fisch; owner: WMDE-Fisch):
[mediawiki/extensions/RevisionSlider@master] Fix errors leading to wrong slider scroll postions

https://gerrit.wikimedia.org/r/360647

Change 360647 merged by jenkins-bot:
[mediawiki/extensions/RevisionSlider@master] Fix errors leading to wrong slider scroll postions

https://gerrit.wikimedia.org/r/360647

Change 360648 had a related patch set uploaded (by Addshore; owner: WMDE-Fisch):
[mediawiki/extensions/RevisionSlider@wmf/1.30.0-wmf.6] Fix errors leading to wrong slider scroll postions

https://gerrit.wikimedia.org/r/360648

Change 360650 had a related patch set uploaded (by Addshore; owner: WMDE-Fisch):
[mediawiki/extensions/RevisionSlider@wmf/1.30.0-wmf.5] Fix errors leading to wrong slider scroll postions

https://gerrit.wikimedia.org/r/360650

Change 360650 merged by jenkins-bot:
[mediawiki/extensions/RevisionSlider@wmf/1.30.0-wmf.5] Fix errors leading to wrong slider scroll postions

https://gerrit.wikimedia.org/r/360650

Change 360648 merged by jenkins-bot:
[mediawiki/extensions/RevisionSlider@wmf/1.30.0-wmf.6] Fix errors leading to wrong slider scroll postions

https://gerrit.wikimedia.org/r/360648

Mentioned in SAL (#wikimedia-operations) [2017-06-21T13:47:07Z] <addshore@tin> Synchronized php-1.30.0-wmf.5/extensions/RevisionSlider/modules/ext.RevisionSlider.SliderView.js: SWAT: [[gerrit:360650|Fix errors leading to wrong slider scroll postions]] T168299 (duration: 00m 46s)

Mentioned in SAL (#wikimedia-operations) [2017-06-21T13:48:28Z] <addshore@tin> Synchronized php-1.30.0-wmf.6/extensions/RevisionSlider/modules/ext.RevisionSlider.SliderView.js: SWAT: [[gerrit:360648|Fix errors leading to wrong slider scroll postions]] T168299 (duration: 00m 44s)

Tobi_WMDE_SW closed this task as Resolved.Jun 21 2017, 3:18 PM

Change 361037 had a related patch set uploaded (by WMDE-Fisch; owner: WMDE-Fisch):
[mediawiki/extensions/RevisionSlider@REL1_27] Fix errors leading to wrong slider scroll positions

https://gerrit.wikimedia.org/r/361037

Change 361037 merged by Tobias Gritschacher:
[mediawiki/extensions/RevisionSlider@REL1_27] Fix errors leading to wrong slider scroll positions

https://gerrit.wikimedia.org/r/361037