Add a hint for membership fee payments by PayPal
Closed, ResolvedPublic3 Story Points

Description

As a user,
I want to understand what PayPal means by stating that the first 90 days of membership are free,
so that I am not confused when the checkout page is displayed.

Acceptance Criteria:

Ihre Mitgliedschaft startet im kommenden Jahr. Der [periode] Mitgliedsbeitrag von [Beitrag] wird durch PayPal am [Tag 1. Abbuchung] abgebucht. Damit PayPal den ersten Beitrag am [Tag 1. Abbuchung] abbuchen kann, sind die Tage bis dahin als "kostenlose Testmitgliedschaft" vermerkt.

  • The notice disappears again when selecting any other payment type.

Background:

  • We are using the "trial period" feature of PayPal's subscriptions to process the first payment transaction when new applicants have already been confirmed by the board. PayPal displays the text "free for the first n days" on their checkout page, which might be confusing.
  • The text to be displayed and a design draft are in the related issue on GitHub.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 23 2017, 1:35 PM
gabriel-wmde updated the task description. (Show Details)Jun 28 2017, 1:49 PM
Pablo-WMDE added a subscriber: Jan_Dittrich.EditedJun 28 2017, 1:49 PM

@Jan_Dittrich @tmletzko Can you please confirm that the linked mock-up is in line with what you expect as outcome for this story?

gabriel-wmde updated the task description. (Show Details)Jun 28 2017, 1:53 PM
gabriel-wmde set the point value for this task to 3.
gabriel-wmde moved this task from Backlog to Sprint ready on the WMDE-Fundraising-Tech board.
Jan_Dittrich added a comment.EditedJun 29 2017, 1:35 PM

Looks good to me – we should take care use the proper quotation marks („ “ » « )

design and layout would have to be adjusted to the new website design and layout though. But I guess it is just about the "pointing box appearing underneath PPL once you chose PPL as a payment option", right ? @Pablo-WMDE

– yes, we should check that, maybe today, if such elements are already included in the new design.

kai.nissen added a comment.EditedJul 14 2017, 4:01 PM

@tmletzko, @Jan_Dittrich

Ihre Mitgliedschaft startet im kommenden Jahr.

This is not true in all cases. In general, it's rather "Ihre Mitgliedschaft startet in drei Monaten".

Der [periode] Mitgliedsbeitrag von [Beitrag] wird durch PayPal am [Tag 1. Abbuchung] abgebucht. Damit PayPal den ersten Beitrag am [Tag 1. Abbuchung] abbuchen kann, sind die Tage bis dahin als "kostenlose Testmitgliedschaft" vermerkt.

Do we really need to be that specific and print out the payment interval, membership fee and the date of first payment? Please keep in mind, that it is about the application form and the placeholders refer to form fields that are below this notice. In most cases the users did not even decide for a membership fee at this point.

Jan_Dittrich added a comment.EditedJul 17 2017, 7:33 AM

This is not true in all cases. In general, it's rather "Ihre Mitgliedschaft startet in drei Monaten".

OK – What is the mechanism behind determining the starting date?

Please keep in mind, that it is about the application form and the placeholders refer to form fields that are
below this notice. In most cases the users did not even decide for a membership fee at this point.

So you can sign up for payment in paypal and the fee is not clear at that point? I am a bit confused – let's talk about this in person, it is probably quicker :)

I talked to @kai.nissen

The first 90 Days are free, because this is the time window in which we can be sure that new members are admitted. So we could write:

»Die Mitgliedschaft bei Wikimedia Deutschland beginnt offiziell 90 Tage nach dem Mitgliedschaftsantrag. Damit PayPal den ersten Beitrag in 90 Tagen abbuchen kann, sind die Tage bis dahin als "kostenlose Testmitgliedschaft" vermerkt.«

We could consider writing always:

»»Die Mitgliedschaft bei Wikimedia Deutschland beginnt offiziell 90 Tage nach dem Mitgliedschaftsantrag.« (to make that transparent, otherwise people may think that PayPal delays their Mitgliedschaft)

And if paypal is choosen we could add the part: »Damit PayPal den ersten Beitrag in 90 Tagen abbuchen kann, sind die Tage bis dahin als "kostenlose Testmitgliedschaft" vermerkt.«

@tmletzko: ping

even though I dislike the impression that memberships always start 90 days later, I can live with

"Ihre Mitgliedschaft bei Wikimedia Deutschland beginnt 90 Tage nach dem Mitgliedschaftsantrag."

BUT

This does not apply for other membership payments. Only PPL due to the delayed payment. So I propose to display both information once you choose PPL

@Jan_Dittrich

@tmletzko

Does this mean that: "90 days is the time window in which we can be sure that new members are admitted."

Is only true in the PayPal case? I thought it is a real world process and thus true for all ways of payments (ping @kai.nissen )

@Jan_Dittrich

No, there is no fixed time process for admission. Basically during the campaign, we only offer a membership starting the following year. To become a member one has to be approved by the board and in addition once shall receive a welcome letter before we make the first payment. The 90 daysdays is a realsitic time window in which those things can happen (membership application campaign start mid-November, welcome letter mid-January, payment mid february).

The unique thing with PPL is that the payment date is fixed and we need to make sure that the above mentionend process is conducted in that time window.

OK, I got it now.

Both PRs have been merged so I think this belongs on deploy

Pablo-WMDE closed this task as Resolved.Mon, Sep 25, 11:29 AM