Page MenuHomePhabricator

Figure out the package conflict between libtidy-dev from sury and hhvm-tidy
Closed, DeclinedPublic

Description

From T169004

hhvm-tidy depends on libtidy-0.99-0

libtidy-dev is provided by sury with Breaks: libtidy-0.99-0 and hence it get installed over hhvm-tidy.

libtidy-dev:
  Installed: (none)
  Candidate: 1:5.2.0-1.1+0~20160628154528.2+jessie~1.gbpabdd25
  Version table:
     1:5.2.0-1.1+0~20160628154528.2+jessie~1.gbpabdd25 0
        500 https://packages.sury.org/php/ jessie/main amd64 Packages
     20091223cvs-1.4+deb8u1 0
        500 http://mirrors.wikimedia.org/debian/ jessie/main amd64 Packages
        500 http://security.debian.org/ jessie/updates/main amd64 Packages

We need to fix up the apt pinning for sury.