Page MenuHomePhabricator

Due to missing fonts on Thumbor hosts, PNG thumbnail of SVG file showing a Devanagari character only displays a Unicode number box
Closed, ResolvedPublic

Description

https://commons.wikimedia.org/wiki/File:Code2000_Devanagari_va%2Bi.svg

The png renderer shows unicode numbers instead of the actual character for the Devanagari script (Hindi language).

Event Timeline

Shyamal created this task.Jun 28 2017, 12:52 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 28 2017, 12:52 PM

@Shyamal: Did Dereckson agree on working on this, or why did you assign this task to him? If not, please unassign.

Cannot reproduce locally, both commands show a proper वि here. Wondering if either some font issue or some thumbnail backend change issue.

$:acko\> rpm -q ImageMagick
ImageMagick-6.9.3.0-6.fc25.x86_64
$:acko\> rpm -q librsvg2
librsvg2-2.40.16-2.fc25.x86_64
$:acko\> convert -resize 300x300 Code2000_Devanagari_va+i.svg Code2000_Devanagari_va+i.png
$:acko\> rsvg-convert -w 300 -h 300 -o Code2000_Devanagari_va+i.png Code2000_Devanagari_va+i.svg
Aklapper renamed this task from RSVG rendering issue with Devanagari Unicode font - Nakula etc. to PNG thumbnail of SVG file including a Devanagari Unicode font character only displays a Unicode number box.Jun 28 2017, 1:48 PM
Shyamal removed Dereckson as the assignee of this task.Jun 28 2017, 1:49 PM
Shyamal added a subscriber: Dereckson.

@Aklapper No, I only added some folks I saw on other rsvg font rendering bugs - I have no idea how this works - in the past I have had bug reports just ignored and then I was told I had to put in the relevant (how can I know who that is?!!) people into the assignee box... Have removed it since you are now aware of this report.

Here is how it looks

Shyamal removed a subscriber: Dereckson.Jun 28 2017, 1:55 PM
Gilles claimed this task.Jun 28 2017, 2:11 PM
Gilles added a subscriber: Gilles.

Could be missing fonts on the Thumbor hosts compared to image scalers, I'll look into that.

Mahir256 added a subscriber: Mahir256.EditedJun 28 2017, 2:22 PM

While the specific bug is quite important to fix, I must note that that particular image is intended to show what it showed before Suyash and Shyamal's recent changes--that is, the appearance of the Devanagari on Wikipedia's logo prior to mid-2010--and thus the specific edits that were made to 'correct' it have been reverted.

See its use here: https://en.wikipedia.org/wiki/Wikipedia:Wikipedia_logos

Confirmed as missing fonts on the Thumbor hosts. The same rsvg-convert command renders fine on image scalers.

Gilles triaged this task as High priority.Jun 28 2017, 2:24 PM

Change 361871 had a related patch set uploaded (by Gilles; owner: Gilles):
[operations/puppet@production] Include fonts role in Thumbor role

https://gerrit.wikimedia.org/r/361871

Change 361871 merged by Filippo Giunchedi:
[operations/puppet@production] Include fonts role in Thumbor role

https://gerrit.wikimedia.org/r/361871

While the specific bug is quite important to fix, I must note that that particular image is intended to show what it showed before Suyash and Shyamal's recent changes--that is, the appearance of the Devanagari on Wikipedia's logo prior to mid-2010--and thus the specific edits that were made to 'correct' it have been reverted.
See its use here: https://en.wikipedia.org/wiki/Wikipedia:Wikipedia_logos

I agree - I also commented likewise to Suyash who requested me to fix what he saw as a problem - https://commons.wikimedia.org/wiki/User_talk:Shyamal#https:.2F.2Fcommons.wikimedia.org.2Fwiki.2FFile:Code2000_Devanagari_va.252Bi.svg

Aklapper renamed this task from PNG thumbnail of SVG file including a Devanagari Unicode font character only displays a Unicode number box to Due to missing fonts on Thumbor hosts, PNG thumbnail of SVG file showing a Devanagari character only displays a Unicode number box.Jun 28 2017, 2:56 PM

Should be fixed now. Purging an affected file should fix its current versions' thumbnails.

Purging doesn't seem to affect older versions' thumbnails, not sure how to/if we can fix those.

The purging issue for older versions has been filed here: T169178: Purging files doesn't purge the thumbnails of older versions At this point I don't know if it's easy or hard to fix.

In the meantime, I'll clean up the current version of affected files, which is what really matters.

Gilles changed the task status from Stalled to Open.Aug 7 2017, 4:57 PM
Gilles closed this task as Resolved.Aug 14 2017, 7:36 PM

All SVGs affected during this bug's timeframe have been purged.