Page MenuHomePhabricator

Styles for babel box aren't loaded in preview of visual wikitext editor
Closed, DuplicatePublic8 Estimated Story Points

Description

While trying to preview a page after adding babel box using the babel extension on a page that hasn't used it before, the styles for the babel box aren't loaded. This happens only with the visual wikitext editor. The old wikitext editor doesn't have this issue.

Steps to reproduce

  1. Go to this sandbox page
  2. Edit it as source
  3. Paste the following line into it {{#babel:en}}
  4. See the preview

Expected output
The babel box is shown with appropriate styles in the preview.

Actual output
The styles are shown only after saving the page. Note : Don't save the sandbox page as a continuation of the steps to reproduce, for this reason!

Screen shot

Note : If this persists, I'm sure that not many would use the babel extension after seeing a preview a like that!

Also mentioned at https://www.mediawiki.org/wiki/Topic:U07b83isigt2hve4.

Related Objects

Event Timeline

Kaartic created this task.Jun 30 2017, 12:56 PM
Restricted Application added a project: VisualEditor. · View Herald TranscriptJun 30 2017, 12:56 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Kaartic updated the task description. (Show Details)Jul 1 2017, 4:33 PM
Deskana triaged this task as Low priority.Jul 25 2017, 7:27 PM
Deskana moved this task from To Triage to TR1: Releases on the VisualEditor board.
Deskana set the point value for this task to 8.Aug 25 2017, 10:31 AM
Restricted Application added a subscriber: jeblad. · View Herald TranscriptAug 25 2017, 10:31 AM
jeblad removed a subscriber: jeblad.Aug 25 2017, 11:45 PM
Elitre updated the task description. (Show Details)Oct 18 2017, 9:10 AM
Elitre added a subscriber: Elitre.Oct 18 2017, 9:14 AM

I am assuming the reason (not loading extension styles) is the same behind the related issues reported for the visual editor?

The problem doesn't appear on my Meta page already, but on @Kaartic's sandbox it still doesn't work well.

Deskana lowered the priority of this task from Low to Lowest.Aug 30 2018, 12:40 PM
Deskana moved this task from TR1: Releases to Freezer on the VisualEditor board.

This works correctly now.

Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptNov 5 2019, 8:44 PM
Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptNov 5 2019, 8:44 PM