Page MenuHomePhabricator

Blacklist UsersMultiselectWidget UI needs improvements
Closed, ResolvedPublic

Description

(1) The initial load of Prefernces-Notificaitons page will display UsersMultiselectWidget input textbox with

  • the close button (X) is not properly centered
  • the close button (X) serves no purpose
  • the abbreviated text: 'Add more...' which is not intelligible. The abbreviation will not be expanded even if some users are entered.

(2) Entering one user name will automatically push the cursor to the next line

(3) Monobook skin will display the close buttons misalogned

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 30 2017, 10:53 PM

Should be done in conjunction with T166626

jrbs moved this task from Backlog to Other team on the Trust-and-Safety board.Jul 7 2017, 10:37 PM

Change 364488 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/core@master] HTMLUsersMultiselectField: Handle empty value properly

https://gerrit.wikimedia.org/r/364488

Change 364488 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/core@master] HTMLUsersMultiselectField: Handle empty value properly
https://gerrit.wikimedia.org/r/364488

This patch fixes the empty bubble, which fixes part of #1 (the close button that serves no purpose) and #3 (because from that screenshot it looks like the close button is only misaligned on the empty bubble).

Change 364524 had a related patch set uploaded (by Catrope; owner: Catrope):
[oojs/ui@master] TagMultiselectWidget: Skip updateInputSize() for invisible inputs

https://gerrit.wikimedia.org/r/364524

Change 364524 had a related patch set uploaded (by Catrope; owner: Catrope):
[oojs/ui@master] TagMultiselectWidget: Skip updateInputSize() for invisible inputs
https://gerrit.wikimedia.org/r/364524

This patch fixes "Add more" being cut off. I couldn't reproduce the input going to the next line last time I tried. Is that specific to Safari?

Change 364524 merged by jenkins-bot:
[oojs/ui@master] TagMultiselectWidget: Skip updateInputSize() for invisible inputs

https://gerrit.wikimedia.org/r/364524

Change 364488 merged by jenkins-bot:
[mediawiki/core@master] HTMLUsersMultiselectField: Handle empty value properly

https://gerrit.wikimedia.org/r/364488

Re-checked in betalabs - it seems that all UI issues are resolved:

  • 'X' button is removed
  • 'Add more...' is fully displayed
  • Entered usernames are displayed properly (even on multiple lines)
  • close button look fine in monobook skin

monobook - usernames on multiple lines

Closing the ticket as resolved

Etonkovidova closed this task as Resolved.Jul 18 2017, 7:37 PM