[Regression pre-wmf.8] "Uncaught TypeError: Cannot read property 'resolve' of null" appears after re-using a reference
Closed, ResolvedPublic1 Story Points

Description

Steps to reproduce:

  1. Insert a citation
  2. Go to Cite>Re-use and select the citation you just added.

Observed Result:

"Uncaught TypeError: Cannot read property 'resolve' of null" appears in the console.

Ryasmeen created this task.Jul 6 2017, 3:04 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 6 2017, 3:04 AM
Deskana triaged this task as High priority.Jul 7 2017, 12:17 PM
Deskana moved this task from To Triage to TR0: Interrupt on the VisualEditor board.
Deskana added a subscriber: Deskana.

I was able to successfully reuse the reference despite the error, so this doesn't break any functionality. Still, this needs investigation to make sure it's not indicative of a larger issue.

DLynch added a subscriber: DLynch.Jul 10 2017, 2:52 PM

I had some trouble reproducing this, until I realized that it only happens if Citoid is present -- the basic Cite extension reuse works just fine.

I think this is fallout from the lifecycle changes made a month ago -- the error implies that we're closing the window multiple times, in a way that the compatibility code doesn't expect to happen.

Change 364227 had a related patch set uploaded (by DLynch; owner: DLynch):
[oojs/ui@master] WindowManager: fix closing promise state check

https://gerrit.wikimedia.org/r/364227

Change 364227 merged by jenkins-bot:
[oojs/ui@master] WindowManager: fix closing promise state check

https://gerrit.wikimedia.org/r/364227

matmarex added a subscriber: matmarex.

Turns out there's a more general issue here, which I described on T170164. The patch above fixes this specific case, though.

Deskana closed this task as Resolved.Jul 10 2017, 6:10 PM
Deskana assigned this task to DLynch.

This specific issue is fixed, so closing as resolved.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptJul 10 2017, 6:10 PM
Jdforrester-WMF set the point value for this task to 1.Jul 11 2017, 7:24 PM
Jdforrester-WMF removed a project: Patch-For-Review.