Page MenuHomePhabricator

MCS requests content from RESTBase using non-normalized titles
Closed, ResolvedPublic

Description

Mobile-Content-Service sometimes requests content from RESTBase using non-normalized titles, primarily using spaces instead of underscores. This makes it hit 301 redirects increasing latency. It's not a huge deal for MCS, but still would be nice to fix. Primarily the bug is present for File pages.

See https://logstash.wikimedia.org/goto/ccc66430d24928936cfe3d369639aa14

Details

Related Gerrit Patches:
mediawiki/services/mobileapps : masterUse db titles when requesting page content from Parsoid

Event Timeline

Pchelolo created this task.Jul 6 2017, 9:29 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

I believe the issue is really that it uses normalized titles when it should be using db titles (getPrefixedDBKey) instead. (Underscores instead of spaces)

I believe the issue is really that it uses normalized titles when it should be using db titles (getPrefixedDBKey) instead. (Underscores instead of spaces)

Ok, we're having terminology issues. I call getPrefixedDBKey a normalized title :)

@Pchelolo Yep. I would have happily concurred with you until I read this:

Title normalization converts page titles to their canonical form. This means capitalizing the first character, replacing underscores with spaces, ...

(OTOH https://www.npmjs.com/package/mediawiki-title seems to use it like you do. But I think the mediawiki.org definition came earlier.)

Change 364517 had a related patch set uploaded (by BearND; owner: BearND):
[mediawiki/services/mobileapps@master] Use db titles when requesting page content from Parsoid

https://gerrit.wikimedia.org/r/364517

Change 364517 merged by jenkins-bot:
[mediawiki/services/mobileapps@master] Use db titles when requesting page content from Parsoid

https://gerrit.wikimedia.org/r/364517

Mentioned in SAL (#wikimedia-operations) [2017-07-12T20:11:00Z] <bsitzmann@tin> Started deploy [mobileapps/deploy@3f90bf1]: Update mobileapps to d30dae2 (T169930, T170225)

Mentioned in SAL (#wikimedia-operations) [2017-07-12T20:16:00Z] <bsitzmann@tin> Finished deploy [mobileapps/deploy@3f90bf1]: Update mobileapps to d30dae2 (T169930, T170225) (duration: 05m 00s)

bearND closed this task as Resolved.Jul 12 2017, 8:17 PM