Page MenuHomePhabricator

Nothing shown in visual diff when editing invisible templates
Closed, ResolvedPublic1 Story Points

Description

On FF56/Mac OS 10.12.15 when you edit the first template of a page, it shows a comment annotating an empty space and shows no content apart from the infobox.

Steps to reproduces

  1. Go to edit the Grace Sherwood article
  2. Edit the Pp-protected template, changing the expiry year from 2017 to 2018
  3. Review your changes, your wikitext diff should look like:

Problems

  1. No way of telling what is happening without looking at the sidebar.
  2. Doesn't tell which template changed.
  3. Doesn't tell which parameters changed.

(from https://www.mediawiki.org/wiki/User:Prtksxna/VeDiff#Edit_first_template )

Details

Related Gerrit Patches:
mediawiki/extensions/VisualEditor : masterUse CE rendering for invisible templates

Event Timeline

Prtksxna created this task.Jul 10 2017, 8:39 AM
Restricted Application added a project: VisualEditor. · View Herald TranscriptJul 10 2017, 8:39 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Prtksxna updated the task description. (Show Details)Jul 10 2017, 8:41 AM
Prtksxna added subscribers: Esanders, Tchanders.
Prtksxna updated the task description. (Show Details)Jul 10 2017, 8:44 AM
Esanders renamed this task from No context shown when editing the first template to Nothing shown in visual diff when editing invisible templates.Jul 10 2017, 11:01 AM

The problem is the template is invisible in the main document - in this case it only outputs to <indicators>

Deskana triaged this task as Low priority.Jul 18 2017, 7:17 PM
Deskana moved this task from To Triage to TR6: Visual diffs on the VisualEditor board.
Prtksxna updated the task description. (Show Details)Jul 20 2017, 11:04 AM

Borrowing the yellow from T169325, and the icons from T170134 we could:


Deskana set the point value for this task to 1.Aug 23 2017, 3:46 PM

Change 432399 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/VisualEditor@master] Use CE rendering for invisible templates

https://gerrit.wikimedia.org/r/432399

Describing the param changes was fixed in T188389 - although we could yet consider the red/green highlights...

Change 432399 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Use CE rendering for invisible templates

https://gerrit.wikimedia.org/r/432399

matmarex closed this task as Resolved.Jun 14 2018, 6:55 PM
matmarex assigned this task to Esanders.
matmarex edited projects, added VisualEditor (Current work); removed VisualEditor.