Page MenuHomePhabricator

Infobox caption causes visual glitches on mobile web
Closed, ResolvedPublic

Description

The <caption class="fn"> (name) of the infobox on https://en.m.wikipedia.org/w/index.php?title=Oscar_Pistorius&oldid=790750320 while on mobile web is glitchy and causes visual glitches.

Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3141.8 Safari/537.36

Can be replicated in Windows 10, Chrome 61 on browserstack.com

Related

Event Timeline

Josve05a created this task.Jul 11 2017, 9:19 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 11 2017, 9:19 PM
Jdlrobson renamed this task from Infobox causes visual glitches on mobile web to Infobox caption causes visual glitches on mobile web.Jul 11 2017, 9:29 PM
Jdlrobson moved this task from To Triage to Needs Analysis on the Readers-Web-Backlog board.
Jdlrobson updated the task description. (Show Details)

Same issue is happening when in a private window, so not a custom userscrpt eller gadget causing this.

The only extentions I have in my browser when incognito is:

  • Instapaper 2.0.3 (ldjkgaaoikpmhmkelcgkgacicjfbofhh)

but I tried turnng it off, and still get this issue, so probl. not an issue on my side.

jrbs added a subscriber: jrbs.Jul 11 2017, 9:45 PM

Issue reproduced on Opera 46.

Since hat article got deleted, here is another article with the same issue https://en.m.wikipedia.org/w/index.php?title=Oscar_Pistorius&oldid=790750320

ovasileva triaged this task as Normal priority.Jul 17 2017, 4:41 PM
ovasileva added subscribers: ABorbaWMF, ovasileva.

@ABorbaWMF - could you try reproducing this across browsers/devices?

Hello, this one is a little strange. I cannot reproduce this on any simulated devices, but I can reproduce it using a desktop browser and the mobile site URL. So far this happens only with Opera.

Simulated devices

Desktop

ovasileva lowered the priority of this task from Normal to Low.Jul 21 2017, 5:43 PM
Jdlrobson updated the task description. (Show Details)Aug 24 2017, 5:41 PM
Jdlrobson updated the task description. (Show Details)Aug 24 2017, 5:48 PM

Change 373623 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/skins/MinervaNeue@master] Caption should inherit background from table

https://gerrit.wikimedia.org/r/373623

Jdlrobson closed this task as Resolved.Aug 24 2017, 6:02 PM
Jdlrobson claimed this task.
Jdlrobson added a subscriber: Jdlrobson.

I was able to narrow this down to a rule in MediaWiki:Mobile.css: https://en.m.wikipedia.org/wiki/Special:MobileDiff/797056133
With that eradicated I was seeing:


This is easily fixed by: https://gerrit.wikimedia.org/r/373623

Change 373623 merged by jenkins-bot:
[mediawiki/skins/MinervaNeue@master] Caption should inherit background from table

https://gerrit.wikimedia.org/r/373623