Page MenuHomePhabricator

Show preview stopped working in Microsoft Edge
Closed, ResolvedPublic1 Estimate Story Points

Description

Approximately on the first day of July 2017, previews stopped working in Microsoft Edge.

Reported by @Daylen at https://www.mediawiki.org/wiki/Topic:Ttz4dqq47z7pvywy (Flow thread contains a link to a video)

Details

Related Gerrit Patches:
mediawiki/extensions/VisualEditor : masterFix wikitext preview in IE and Edge

Event Timeline

Restricted Application added a project: VisualEditor. · View Herald TranscriptJul 12 2017, 7:23 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Does anyone in the team have a device that has Edge?

matmarex claimed this task.Jul 12 2017, 7:43 PM
matmarex added a subscriber: matmarex.

Yes. I'll look into it.

We also have crossbrowsertesting accounts although they're a little slower.

The issue is on Microsoft Edge 40.15063.0.0 on Windows 10 Pro Insider Edition (build 15063).

Deskana triaged this task as Medium priority.Jul 13 2017, 9:58 PM
Deskana moved this task from To Triage to TR1: Releases on the VisualEditor board.

Error message:

SCRIPT438: Object doesn't support property or method 'forEach'
ve.ui.MWSaveDialog.js (188,3)
		body.querySelectorAll( 'link[rel="mw:PageProp/Category"]' ).forEach( function ( element ) {
			categories.push( ve.dm.MWCategoryMetaItem.static.toDataElement( [ element ] ).attributes.category );
		} );

Change 365245 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/VisualEditor@master] Fix wikitext preview in IE and Edge

https://gerrit.wikimedia.org/r/365245

Error message:

SCRIPT438: Object doesn't support property or method 'forEach'
ve.ui.MWSaveDialog.js (188,3)
		body.querySelectorAll( 'link[rel="mw:PageProp/Category"]' ).forEach( function ( element ) {
			categories.push( ve.dm.MWCategoryMetaItem.static.toDataElement( [ element ] ).attributes.category );
		} );

Yes, I can confirm that this is the same issue displaying on my version of Edge

Change 365245 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Fix wikitext preview in IE and Edge

https://gerrit.wikimedia.org/r/365245

Deskana closed this task as Resolved.Jul 17 2017, 3:11 PM
Deskana set the point value for this task to 1.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptJul 17 2017, 3:11 PM

Has the change been merged into the English Wikipedia, as I am still having the problem there?

Has the change been merged into the English Wikipedia, as I am still having the problem there?

Not yet, the fix is merged into the beta cluster. It will be released as part of 1.30.0-wmf.10 on English Wikipedia on Thursday, July 20. You can check https://www.mediawiki.org/wiki/MediaWiki_1.30/Roadmap#10 for the schedule.

Has the change been merged into the English Wikipedia, as I am still having the problem there?

Not yet, the fix is merged into the beta cluster. It will be released as part of 1.30.0-wmf.10 on English Wikipedia on Thursday, July 20. You can check https://www.mediawiki.org/wiki/MediaWiki_1.30/Roadmap#10 for the schedule.

It is working now! Thank you everyone involved in fixing this.

Izno added a subscriber: Izno.EditedJul 25 2017, 2:28 PM

I have an install of IE11 on Windows 7 at work and I am still seeing the hanging behavior today on en.WP (wmf10 was merged as expected) even after clearing my cache and doing a hard refresh.

It looks like I don't have access to console either else I would try to get a snapshot out of there (group policy? dumb....).

I see that too on Windows 10. That's IE11 only, Edge works fine. I filed another task since it seems like a separate problem: T171600: Show preview stopped working in IE 11.