"Unknown dependency: wikibase.mobile" on Wikidata element pages
Closed, ResolvedPublic

Description

I get this error when visiting element pages at Wikidata now. I still get it when logged out, so not related to gadgets or userscripts. Same error in Chrome and Firefox.

Exception in resolve:
load.php?debug=true&lang=nb&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=…:13121 Error: Unknown dependency: wikibase.mobile Error: Unknown dependency: wikibase.mobile
    at sortDependencies (load.php?debug=true&lang=nb&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=…:11459)
    at resolveStubbornly (load.php?debug=true&lang=nb&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=…:11539)
    at Object.load (load.php?debug=true&lang=nb&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=…:12443)
    at Q7665370?debug=1:270
    at startUp (load.php?debug=true&lang=nb&modules=startup&only=scripts&skin=vector:9139)
    at HTMLScriptElement.script.onload.script.onreadystatechange (load.php?debug=true&lang=nb&modules=startup&only=scripts&skin=vector:9165)
logError @ load.php?debug=true&lang=nb&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=…:13121
handler @ load.php?debug=true&lang=nb&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=…:10965
fire @ load.php?debug=true&lang=nb&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=…:3148
fireWith @ load.php?debug=true&lang=nb&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=…:3260
fire @ load.php?debug=true&lang=nb&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=…:3267
track @ load.php?debug=true&lang=nb&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=…:10941
resolveStubbornly @ load.php?debug=true&lang=nb&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=…:11544
load @ load.php?debug=true&lang=nb&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=…:12443
(anonymous) @ Q7665370?debug=1:270
startUp @ load.php?debug=true&lang=nb&modules=startup&only=scripts&skin=vector:9139
script.onload.script.onreadystatechange @ load.php?debug=true&lang=nb&modules=startup&only=scripts&skin=vector:9165
load.php?debug=true&lang=nb&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=…:9836 GET https://www.wikidata.org/w/extensions/Wikidata/vendor/wikibase/data-model-javascript/src/Fingerprint.js?1b448 net::ERR_BLOCKED_BY_CLIENT
send @ load.php?debug=true&lang=nb&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=…:9836
ajax @ load.php?debug=true&lang=nb&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=…:9215
addScript @ load.php?debug=true&lang=nb&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=…:11561
(anonymous) @ load.php?debug=true&lang=nb&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=…:11591
(anonymous) @ load.php?debug=true&lang=nb&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=…:11600
fire @ load.php?debug=true&lang=nb&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=…:3148
fireWith @ load.php?debug=true&lang=nb&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=…:3260
done @ load.php?debug=true&lang=nb&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=…:9314
script.onload.script.onreadystatechange @ load.php?debug=true&lang=nb&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=…:9829
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 14 2017, 10:12 AM

I also get this error message in the JavaScript console on Wikidata.

Zache triaged this task as High priority.Jul 20 2017, 8:15 PM
Zache added a subscriber: Zache.

Confirmed. I raised the priority to high because this prevents the editing of the wikidata if bug hits before property edit buttons are added.

I get this message in the JavaScript console on Wikidata with :

Operating system

  • Windows 7 pro

Browser

  • Chrome ( 59.0.3071.115)
  • Firefox (54.0.1 (32-bittinen))
  • Internet Explorer (Internet Explorer: 11.0.9600.18738)

Page:

I got error

  • when I was not logged in
  • when i was not logged in and used debug mode
  • i was logged in and settings was reset to default
  • i was logged in and settings was reset to default and all gadgets were removed
  • i was logged in and settings was reset to default and all gadgets were removed and i used the debug mode

How it effects:

  • There is error message in the log like the topic says and property add / edit links aren't rendered.
Nikki added a subscriber: Nikki.Jul 21 2017, 3:39 AM

I'm also having the same problem with not being able to edit on quite a few pages. I tried refreshing, but that doesn't help. Purging the page makes it editable again, but having to do that for every affected page before I can edit is rather inconvenient.

Zache added a comment.Jul 21 2017, 7:28 AM

Purge seems to change the load order so that one can edit the page. "Unknown dependency: wikibase.mobile Error" is still there after purge and if debug-mode is used then add/edit links are missing again.

Change 366853 had a related patch set uploaded (by Hoo man; owner: Hoo man):
[mediawiki/extensions/Wikibase@master] Use addModuleStyles for adding mobile styles

https://gerrit.wikimedia.org/r/366853

Restricted Application added a subscriber: PokestarFan. · View Herald TranscriptJul 21 2017, 2:11 PM

Not sure I understand what's happening here.
https://github.com/wikimedia/mediawiki-extensions-Wikidata/blob/6577cec77a28c088e269671b6b69c095463c30fa/extensions/Wikibase/view/resources/wikibase/resources.php#L42
sets a target of 'mobile'

Thus if you load it on a desktop target it will throw this exception.

if it's supposed to be loaded on mobile change the targets field to desktop, mobile
If it's not you should be adding it via an appropriate hook e.g. https://www.mediawiki.org/wiki/Extension:MobileFrontend/MobileSiteOutputPageBeforeExec

Same here, here's a screenshot of the problem: while I get an "edit" button for labels and sitelinks, I cannot edit the properties.

I run into the same problem, No edit buttons on https://www.wikidata.org/wiki/Q24074537

Error: Unknown dependency: wikibase.mobile Error: Unknown dependency: wikibase.mobile
Stack trace:
sortDependencies@https://www.wikidata.org/w/load.php?debug=false&lang=en&modules=jquery%2Cmediawiki%7Cmediawiki.legacy.wikibits&only=scripts&skin=vector&version=18ol06u:159:205
resolveStubbornly@https://www.wikidata.org/w/load.php?debug=false&lang=en&modules=jquery%2Cmediawiki%7Cmediawiki.legacy.wikibits&only=scripts&skin=vector&version=18ol06u:160:360
load@https://www.wikidata.org/w/load.php?debug=false&lang=en&modules=jquery%2Cmediawiki%7Cmediawiki.legacy.wikibits&only=scripts&skin=vector&version=18ol06u:171:122
@https://www.wikidata.org/wiki/Q24074537:10:4
startUp@https://www.wikidata.org/w/load.php?debug=false&lang=en&modules=startup&only=scripts&skin=vector:75:372
script.onreadystatechange@https://www.wikidata.org/w/load.php?debug=false&lang=en&modules=startup&only=scripts&skin=vector:75:882

logError https://www.wikidata.org/w/load.php:177:330
handler https://www.wikidata.org/w/load.php:155:832
fire https://www.wikidata.org/w/load.php:45:104
fireWith https://www.wikidata.org/w/load.php:46:431
fire https://www.wikidata.org/w/load.php:46:474
track https://www.wikidata.org/w/load.php:155:614
resolveStubbornly https://www.wikidata.org/w/load.php:160:425
load https://www.wikidata.org/w/load.php:171:122
<anonymous> https://www.wikidata.org/wiki/Q24074537:10:4
startUp https://www.wikidata.org/w/load.php:75:372
script.onreadystatechange https://www.wikidata.org/w/load.php:75:882

And I get some extra warnings I'm not sure are related:

This page is using the deprecated ResourceLoader module "jquery.ui.position". load.php:77:291
This page is using the deprecated ResourceLoader module "jquery.ui.widget". load.php:108:942
This page is using the deprecated ResourceLoader module "jquery.ui.core".
Please use "mediawiki.ui.button" or "oojs-ui" instead. load.php:20:84
This page is using the deprecated ResourceLoader module "jquery.jStorage".
Please use "mediawiki.storage" instead. load.php:535:947
This page is using the deprecated ResourceLoader module "jquery.tipsy". load.php:584:171
Your skin is incompatible with VisualEditor. See https://www.mediawiki.org/wiki/VisualEditor/Skin_requirements for the requirements. load.php:478:604

Multichill renamed this task from "Unknown dependency: wikibase.mobile" on Wikidata element pages to "Unknown dependency: wikibase.mobile" on Wikidata element pages .Jul 22 2017, 9:33 AM
Multichill added a subscriber: Lydia_Pintscher.
hoo added a subscriber: hoo.Jul 22 2017, 12:08 PM

My fix should probably backported next week. After that old parser caches will need to be invalidated, as the mobile only module is still in them.

hoo claimed this task.Jul 22 2017, 12:08 PM

Change 366853 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Only add the "wikibase.mobile" module when appropriate

https://gerrit.wikimedia.org/r/366853

Change 367343 had a related patch set uploaded (by Aude; owner: Hoo man):
[mediawiki/extensions/Wikibase@wmf/1.30.0-wmf.10] Only add the "wikibase.mobile" module when appropriate

https://gerrit.wikimedia.org/r/367343

Change 367343 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@wmf/1.30.0-wmf.10] Only add the "wikibase.mobile" module when appropriate

https://gerrit.wikimedia.org/r/367343

aude added a subscriber: aude.Jul 24 2017, 1:14 PM

Fix for this is deployed now

aude closed this task as Resolved.Jul 24 2017, 1:14 PM
aude removed a project: Patch-For-Review.

After that old parser caches will need to be invalidated, as the mobile only module is still in them.

What about this part? Was this also done?

hoo added a comment.Jul 24 2017, 8:47 PM

After that old parser caches will need to be invalidated, as the mobile only module is still in them.

What about this part? Was this also done?

Yes, in ff904e18f61f52dc3e86ab76850e14e49ab15e7d.

I raised the priority to high because this prevents the editing of the wikidata if bug hits before property edit buttons are added.

The console warning Unknown dependency: wikibase.mobile may've looked like a fatal error (including stack trace), but I'm fairly sure it will not have caused edit buttons to not appear or any other sort of cascading failure. This error is an internal exception that is caught and logged to the console without affecting the loading of any other modules. The warning was recently introduced (previously it would be silently caught without logging). Given it looked new, that may've been why you associated the edit-button bug with this warning (but more likely being a "red herring").

This was a non-fatal error with no on-page impact. The commit that fixes the warning did so by not loading the module (meaning, same effective behaviour as before, but without the warning). As such, it seems unnecessary to have invalidated the entire parser cache on wikidata.org just to avoid a no-op warning from showing up in browser consoles to logged-in users for a few more days (whilst naturally rolling over the cache).