VisualEditor Error on Insert menu
Closed, ResolvedPublic0 Story Points

Description

Hello,

I run a wiki on Mediawiki 1.28.2 with the last version of VisualEditor for REL1_28 (93528b73e355).
The extensions seems to work, but I'm facing an error (in my browser's console) when I try to use the Insert > Media menu:

Uncaught TypeError: doc.cloneWithData is not a function
    at VeUiMWMediaDialog.mw.loader.implement.ve.ui.MWMediaDialog.resetCaption (load.php?debug=false&lang=fr&modules=ext.cite.style%2CvisualEditor|ext.cite.visualEditor.core%2Cdat…:1093)
    at VeUiMWMediaDialog.<anonymous> (load.php?debug=false&lang=fr&modules=ext.cite.style%2CvisualEditor|ext.cite.visualEditor.core%2Cdat…:1090)
    at Object.eval (eval at <anonymous> (load.php?debug=false&lang=fr&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=1iff7ao:4), <anonymous>:75:183)
    at Object.<anonymous> (load.php?debug=false&lang=fr&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=1iff7ao:47)
    at fire (load.php?debug=false&lang=fr&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=1iff7ao:45)
    at Object.add [as done] (load.php?debug=false&lang=fr&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=1iff7ao:45)
    at Array.<anonymous> (load.php?debug=false&lang=fr&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=1iff7ao:47)
    at Function.each (load.php?debug=false&lang=fr&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=1iff7ao:5)
    at Object.<anonymous> (load.php?debug=false&lang=fr&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=1iff7ao:47)
    at Function.Deferred (load.php?debug=false&lang=fr&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=1iff7ao:47)
mw.loader.implement.ve.ui.MWMediaDialog.resetCaption @ load.php?debug=false&lang=fr&modules=ext.cite.style%2CvisualEditor|ext.cite.visualEditor.core%2Cdat…:1093
(anonymous) @ load.php?debug=false&lang=fr&modules=ext.cite.style%2CvisualEditor|ext.cite.visualEditor.core%2Cdat…:1090
(anonymous) @ VM138:75
(anonymous) @ load.php?debug=false&lang=fr&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=1iff7ao:47
fire @ load.php?debug=false&lang=fr&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=1iff7ao:45
add @ load.php?debug=false&lang=fr&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=1iff7ao:45
(anonymous) @ load.php?debug=false&lang=fr&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=1iff7ao:47
each @ load.php?debug=false&lang=fr&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=1iff7ao:5
(anonymous) @ load.php?debug=false&lang=fr&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=1iff7ao:47
Deferred @ load.php?debug=false&lang=fr&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=1iff7ao:47
then @ load.php?debug=false&lang=fr&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=1iff7ao:46
OO.ui.Process.execute @ VM138:75
OO.ui.Window.setup @ VM138:90
(anonymous) @ VM138:80

Every other Insert option (Insert template, comment, etc.) seems to work as expected.
Does anyone has already encountered this kind of error ?

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 15 2017, 2:55 PM

@Linedwell We don't have much time to help debug issues with third-party users of our code, I'm afraid. Try upgrading everything to the latest version, and hopefully that will fix things. :-)

Linedwell added a comment.EditedJul 18 2017, 7:32 PM

@Deskana OK, we'll wait for our next Mediawiki (and Extensions) update to see if the bug is solved or if we should stop using VE. Thank you for your answer and your time.

Also make sure you have the latest version of lib/ve that goes with your VE extension (use git submodule update). It looks like they may be out of sync.

Linedwell closed this task as Resolved.Jul 19 2017, 12:04 PM
Linedwell claimed this task.

@Esanders Thank you so much, the submodule update solved my problem, now VE works as intended.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptJul 19 2017, 12:04 PM
Deskana set the point value for this task to 0.Jul 19 2017, 12:05 PM

@Linedwell I'm glad it worked out. :-)