Page MenuHomePhabricator

Update rsvg to 2.40.18
Closed, ResolvedPublic

Event Timeline

Gilles triaged this task as Medium priority.Jul 17 2017, 1:19 PM
Gilles created this task.

We can't easily do that on jessie; 2.4.17 moved partly to rustc and jessie doesn't have the necessary toolchain. ATM 2.4.17 isn't even present in Debian unstable.

Doesn't seem to be the source of the problem anyway, after further inspection.

We can't easily do that on jessie; 2.4.17 moved partly to rustc and jessie doesn't have the necessary toolchain. ATM 2.4.17 isn't even present in Debian unstable.

(For the records, the librsvg 2.4.18 release announcement states "This is the stable series without Rust code; it's only shaky C code for your perusal.")

Gilles renamed this task from Update rsvg to 2.40.17 to Update rsvg to 2.40.18.Jul 22 2017, 6:51 AM
Gilles updated the task description. (Show Details)
MoritzMuehlenhoff claimed this task.

Sorry, I confused that with the 2.41 branch (which uses rust). I'll take care of upgrading librsvg.

I've built a backport of 2.40.18 and uploaded it to apt.wikimedia.org. I verified that https://upload.wikimedia.org/wikipedia/commons/1/16/Map_of_Texas_highlighting_Armstrong_County.svg segfaults with 2.40.16 and works fine with the 2.40.18 backport.

Nevermind, I see the parent bug is still open.

@kaldari it's the same bug, the same as the parent in fact: T170628 The actual solution will probably be T170817