Thank button broken on mobilefrontend - displays "{{GENDER:[object Object]|{{GENDER:unknown|Thank}}}}"
Closed, ResolvedPublic

Description

Steps to recreate:

  1. go to https://en.m.wikipedia.org/wiki/Columbia_River
  2. select "last edited" (page history)
  3. select the edit from 02:39 from Randy Kryn

Expected behavior:

  • thank button appears with icon

Observed behavior:

  • thank button broken

Note: can't reproduce on all pages

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 18 2017, 11:22 AM
ovasileva triaged this task as High priority.Jul 18 2017, 11:22 AM
Aklapper renamed this task from Thank button broken on mobilefrontend to Thank button broken on mobilefrontend - displays "{{GENDER:[object Object]|{{GENDER:unknown|Thank}}}}".Jul 18 2017, 12:02 PM
Aklapper added projects: MobileFrontend, Thanks.
Aklapper updated the task description. (Show Details)

regression we should fix - moving this into the sprint

It might be related to caching issue, as if I visit this page with debug=true I don't see the error (https://en.m.wikipedia.org/wiki/Special:MobileDiff/791098920?debug=true vs https://en.m.wikipedia.org/wiki/Special:MobileDiff/791098920)

I tried this a bunch of times using the article listed above. Twice, out of the approximately 40 times, I viewed an edit where the thanks button was wonky. I'm not sure how I triggered it, but it was after a lot of tapping on past edits.

Change 366028 had a related patch set uploaded (by Mattflaschen; owner: Mattflaschen):
[mediawiki/extensions/Thanks@master] Add missing jQueryMsg dependency for mobile diff view

https://gerrit.wikimedia.org/r/366028

The above should fix it (it works locally).

There was a missing dependency, which means it's unpredictable (depending on what other extensions and features are on the page, and other factors) whether the module will work correctly.

It might be related to caching issue, as if I visit this page with debug=true I don't see the error (https://en.m.wikipedia.org/wiki/Special:MobileDiff/791098920?debug=true vs https://en.m.wikipedia.org/wiki/Special:MobileDiff/791098920)

In this case, something else is probably coincidentally loading mediawiki.jQueryMsg, but not early enough. It's common for the load order to be different in debug mode, hiding these issues.

Change 366028 merged by jenkins-bot:
[mediawiki/extensions/Thanks@master] Add missing jQueryMsg dependency for mobile diff view

https://gerrit.wikimedia.org/r/366028

Change 366168 had a related patch set uploaded (by Jdlrobson; owner: Mattflaschen):
[mediawiki/extensions/Thanks@wmf/1.30.0-wmf.9] Add missing jQueryMsg dependency for mobile diff view

https://gerrit.wikimedia.org/r/366168

Jdlrobson added a subscriber: Jdlrobson.

It's fixed on MediaWiki.org (https://m.mediawiki.org/wiki/Special:MobileDiff/2509350). I've added this to the swat calendar to fix wmf9.

Change 366168 merged by jenkins-bot:
[mediawiki/extensions/Thanks@wmf/1.30.0-wmf.9] Add missing jQueryMsg dependency for mobile diff view

https://gerrit.wikimedia.org/r/366168

Mentioned in SAL (#wikimedia-operations) [2017-07-18T23:27:28Z] <thcipriani@tin> Synchronized php-1.30.0-wmf.9/extensions/Thanks/extension.json: SWAT: [[gerrit:366168|Add missing jQueryMsg dependency for mobile diff view]] T170917 (duration: 00m 47s)

Verified fixed on wmf9. Thanks @Mattflaschen-WMF for getting this fixed :)

phuedx closed this task as Resolved.Jul 19 2017, 7:59 AM
phuedx added a subscriber: phuedx.

LGTM! I tested this on en.m. and it looks as if @Jdlrobson has too (T170917#3450738).

Jdlrobson reopened this task as Open.Jul 21 2017, 6:54 PM
Jdlrobson added a subscriber: MaxSem.

cc @MaxSem apparently this fix didn't make it into wmf10....

Change 366899 had a related patch set uploaded (by Mattflaschen; owner: Mattflaschen):
[mediawiki/extensions/Thanks@wmf/1.30.0-wmf.10] Add missing jQueryMsg dependency for mobile diff view

https://gerrit.wikimedia.org/r/366899

looked at this quickly today and the thank button seems to be missing

@ovasileva button is there and the issue still exists on production servers.

See https://phabricator.wikimedia.org/T170917#3461506 onwards. It's scheduled for SWAT at 11am.

Change 366899 merged by jenkins-bot:
[mediawiki/extensions/Thanks@wmf/1.30.0-wmf.10] Add missing jQueryMsg dependency for mobile diff view

https://gerrit.wikimedia.org/r/366899

Mentioned in SAL (#wikimedia-operations) [2017-07-24T18:13:40Z] <reedy@tin> Synchronized php-1.30.0-wmf.10/extensions/Thanks/extension.json: T170917 (duration: 00m 43s)

Catrope closed this task as Resolved.Jul 24 2017, 6:29 PM