Page MenuHomePhabricator

Wikistats2 bugs (2/4) - Wiki selector
Closed, ResolvedPublic8 Story Points

Description

  • The wiki selector does not work when selecting a cross-language project like Wikipedia - All languages. The new chosen values show up in the selector, but the data is not loaded, and if you navigate to the detail page or reload, the selection goes back to the initial default (All projects, all languages).

Likewise, If both project and language are selected (say Achinese Wikipedia) the selector does not let you select a cross-language project like Wikipedia - All languages. When you try that, it directly shows the initial default as well.


  • If you choose a value in the wiki selector, the cursor stays in there, and you're able to continue writing or delete characters. If you do so and then click outside of the box, the selector blocks and can not be used any more.

Tasked T173373 - [x] Sometimes (like in the initial default case) the wiki selector can not display the whole text in it because of fixed width, and there's no other place in the layout that this information is displayed. So, the user can not see which exact data is shown.


  • The following is not a bug, but a usability thing: Is "All project families - All projects" OK? Isn't the repetition of the word project a bit confusing? We maybe could use "All project families - All languages", no?

Event Timeline

mforns created this task.Jul 18 2017, 2:05 PM
Restricted Application added subscribers: Cosine02, Aklapper. · View Herald TranscriptJul 18 2017, 2:05 PM
fdans claimed this task.Jul 24 2017, 4:24 PM
fdans edited projects, added Analytics-Kanban; removed Analytics.
fdans set the point value for this task to 8.
fdans moved this task from Next Up to Paused on the Analytics-Kanban board.Jul 26 2017, 1:56 PM
fdans moved this task from Paused to In Progress on the Analytics-Kanban board.
fdans updated the task description. (Show Details)Aug 4 2017, 11:53 PM
fdans updated the task description. (Show Details)
fdans moved this task from Ready to Deploy to Done on the Analytics-Kanban board.Aug 24 2017, 11:40 AM
Milimetric added a subscriber: Milimetric.EditedSep 13 2017, 3:48 PM

The first part of the task, dealing with "Something - All Languages" no longer applies. We disabled this until we have endpoints for it in AQS.

fdans added a comment.Sep 13 2017, 3:55 PM

@Milimetric that last one has been retasked - T173373

gotcha, editing comment

Milimetric closed this task as Resolved.Sep 13 2017, 4:57 PM
Milimetric triaged this task as Normal priority.
Milimetric moved this task from In Code Review to Done on the Analytics-Kanban board.