Page MenuHomePhabricator

Show important indicators in print styles
Closed, DeclinedPublic

Description

Problem

We show indicators by default on print styles. sometimes these indicators are not relevant at all in print medium.
E.g. mw-indicator-spoken-icon

Solution

Identify indicators that could be helpful in print medium and make vectorized print friendly version of it

Useful indicators

  1. Featured article
  2. Semi protected flag

Design

Zeplin spec: https://zpl.io/26T0fw

Related Objects

StatusSubtypeAssignedTask
ResolvedJKatzWMF
ResolvedTheDJ
DuplicateNone
ResolvedJKatzWMF
DeclinedNone
OpenNone
Resolvedpmiazga
InvalidNone
OpenNone
Resolvedovasileva
InvalidNone
Resolvedphuedx
OpenNone
InvalidNone
InvalidNone
ResolvedJdlrobson
DuplicateNone
Resolved Nirzar
OpenNone
DeclinedJdlrobson

Event Timeline

Nirzar updated the task description. (Show Details)

Note to engineers, this changes the design for T169826: Add project wordmark to print styles

I will update the zeplin for that

ovasileva raised the priority of this task from Medium to High.Jul 21 2017, 10:45 AM
matmarex removed a subscriber: matmarex.Jul 22 2017, 7:50 PM

A few things we talked about

  • Are we blacklisting all indicators? How? By classname (mw-indicator-*)?
    • Or are we just swapping those two?
  • Are the vector designs for those two in the description done?
  • Where does the pointage come from? (it has a 5)

Open questions

  1. what are all the indicators in use?
  2. extension adding indicators?
  3. hide all indicators and only show 2 indicators as strategy?
  4. what happens when the title is long
  5. can we get localized string "semi-protected" "featured"
Nirzar removed the point value for this task.Aug 2 2017, 4:21 PM

Are we blacklisting all indicators? How? By classname (mw-indicator-*)?

We are hiding them in print styles. In Minerva we do not render them. In Vector they are rendered.

Where does the pointage come from? (it has a 5)

Story points are inherited when you create a subtask. :)

what are all the indicators in use?

I'm not sure if they are audited. Looks like any number of arbitrary indicators can be created.
https://www.mediawiki.org/wiki/Help:Page_status_indicators
https://en.wikipedia.org/wiki/Template:Featured_article contains featured article indicator.
https://en.wikipedia.org/wiki/Template:Top_icon seems to be the place where it's called. Looking at the "See also" heading of that page will showyou an idea of which indicators exist.

extension adding indicators?

Not sure what this means. They are provided by core. Any skin can control what to do with them.

hide all indicators and only show 2 indicators as strategy?

I think you are going to struggle here to know which 2 to show. All indicators are created equally.

can we get localized string "semi-protected" "featured"

Indicators are content - so will only be localised per page. A tooltip is provided "This is a featured article. Click here for more information." but nothing short which is what I think you are asking for.

Nirzar changed the task status from Open to Stalled.Aug 28 2017, 7:49 PM
Nirzar added subscribers: Jan_Dittrich, TheDJ.

From Discussion with @TheDJ @Jan_Dittrich around the usefulness of indicators at wikimania 2017

  • There doesn't seem to be a strong usecase for having these indicators in print
  • The value of having it vs the effort of adding them is not justified

Changing the status to Stalled until further discussion/requests

@bmansurov, @ovasileva can we remove this as a blocker on T169738?

This is not a blocker of T169738, is it? If it is, then yes, we can remove it.

@Niedzielski subtasks are not blockers afaik

I can confirm this is not a blocker

alexhollender lowered the priority of this task from High to Medium.Jun 4 2019, 3:55 PM
alexhollender moved this task from Needs analysis to Queue on the Readers-Web-Backlog (Design) board.
alexhollender added a subscriber: alexhollender.

Lowering priority as this hasn't been discussed since August 2017

Jdlrobson moved this task from Feature requests to Needs Design on the Vector board.
Jdlrobson closed this task as Declined.Jan 15 2020, 8:01 PM

We show indicators by default on print styles

This is not true.

To clarify the current position - indicators are hidden in print mode via a CSS rule in mediawiki core that lives in src/mediawiki.legacy/commonPrint.css

I'm thus declining given it doesn't seem to be a priority.

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptJan 15 2020, 8:01 PM