Page MenuHomePhabricator

Image move to existing URL shows "Object"
Closed, DeclinedPublic

Description

Author: morbus

Description:
I've been using the new image moving/redirect code in 1.13.0rc1 a lot and am quite pleased - there's no breakage to report (either from a URL rename, redirect, or filename standpoint). There is one minor bauble with the user interface when it comes to renaming a file to an existing file.

  1. Head to Special:MovePage/IMAGE_1.jpg.
  1. These docs state that "Note that the page will not be moved if there is already a page at the new title, unless it is empty or a redirect and has no past edit history. This means that you can rename a page back to where it was renamed from if you make a mistake, and you cannot overwrite an existing page."
  1. For "To new title", enter the name of an existing IMAGE_2. Click "Move page".
  1. First up, the result is "hey, it exists. do you really want to do this?" which seems to contradict #2 above (which suggests it's not gonna do it for existing images, no way no how).
  1. Secondly, and the real bug, is that "Object" is shown, not IMAGE_2: "The destination page "Object" already exists. Do you want to delete it to make way for the move?"

Version: 1.13.x
Severity: normal

Details

Reference
bz15114

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 21 2014, 10:17 PM
bzimport set Reference to bz15114.
bzimport added a subscriber: Unknown Object (MLST).
vvv added a comment.Dec 30 2008, 1:06 AM

It displays correct image name for me. As for point 4, I reported it to the Betawiki and will fix tomorrow.

Gilles moved this task from Untriaged to Done on the Multimedia board.