Page MenuHomePhabricator

Build and push a new hhvm-luasandbox package
Closed, ResolvedPublic

Description

Please update the hhvm-luasandbox Debian package with the changes on the current master branch, and push it out to the servers.

Thanks.

Event Timeline

I'll take care of that early next week.

See also T171267: Deploy LuaSandbox 2.0.13 where Tim started to look at this independently.

Should this task be unbreak now, as it is blocker/possible root cause for T170039 which generate thousands of errors?

Anyway, what is the current status for this?

Thanks, Eran

eranroz raised the priority of this task from High to Unbreak Now!.Aug 12 2017, 6:55 PM

For the current status I'm not sure. In T171267 @tstarling mentioned tests in deployment-prep. If those were successful, we proceed with the actual rollout in production.

The status is just what I wrote in the task description of T171267, I haven't done any more work on it since then, except for merging another change into master. I built a package for trusty, but not for jessie. Building a package for jessie will require at least updating the control file. I haven't tested it in deployment-prep.

I built new jessie packages based on the 2.0.13 release from Github. They're rolled out in deployment-prep on deployment-mediawiki04, deployment-mediawiki05 and deployment-mediawiki06 (with HHVM restarted). A quick test with a PHP script using a Luasandbox was fine, but this needs some more tests in deployment-prep by someone more familiar with the extension (@Anomie or @tstarling , could you do that?) If all tests are fine, we can start upgrading the production cluster on Monday.

If there's a way to run the Scribunto "--group LuaSandbox" phpunit tests with the new version, that'd be a decent test of things generally working.

As for the known bugs:

  • T158029 seems to be fixed.
  • Unfortunately T166348/T170039 need a lot of editing activity to be confident that it really did make the messages disappear.
    • I don't even see the warnings from T166348 in older hhvm.log files on deployment-fluorine02 so there probably has never been enough edit traffic there to trigger the bug in the first place.
  • The fix for T171392 isn't included in the 2.0.13 release.
    • I note the test case from T171392#3463694 no longer fails on Commons so we have no on-wiki test case to use when a version with 76e846467 is built. The command line test in T171392#3467215 should still work, although unit tests added in 76e846467 test that already.

If there's a way to run the Scribunto "--group LuaSandbox" phpunit tests with the new version, that'd be a decent test of things generally working.

I ran the extension test suite in mediawiki-vagrant with 2.0.13 and that worked fine. Will proceed with upgrading the canary app servers next.

The mwdebug* servers, the canary application servers (mw1261-mw1265) and the canary API servers (mw1276-mw1279) have been upgraded to 2.0.13. Looks all fine so far, will keep an eye on it and if nothing comes upgrade additional servers tomorrow.

The migrated canary servers are looking fine. I was initially irritated by https://phabricator.wikimedia.org/T173705, but that also occurs independant of the new luasandbox package. I'm proceeding with upgrading half of the remaining app servers in eqiad.

The following hosts were upgraded to 2.0.13 (and HHVM restarted):

mw1161-mw1167 (job runners)
mw1180-mw1188 (app servers)
mw1209-mw1220 (app servers)
mw1189-mw1208 (API servers)
mw1293-mw1295 (image scalers)
deployment servers (tin, naos)
scripts runners (terbium, wasat)
osmium

If no further problems arise, I'll migrate the remaining hosts tomorrow.

The migrated canary servers are looking fine. I was initially irritated by https://phabricator.wikimedia.org/T173705, but that also occurs independant of the new luasandbox package.

That looks like T171392. A fix for that has been merged, but not in time for the 2.0.13 version being deployed here.

MoritzMuehlenhoff closed this task as Resolved.Aug 23 2017, 10:19 AM

2.0.13 has been built for jessie and deployed in our environment. I don't think we need a trusty build at this point; the video scalers will be reimaged soon (after Theora video is disabled this week) and silver will be moved to a new jessie-based host as well.