Page MenuHomePhabricator

Notifications flyout footer has an unwanted margin
Closed, ResolvedPublic

Description

Seen on all wikis I've visited today, on Firefox or Chromium: an important margin, tabs are offset and there is a grey background.

One example among many:

Event Timeline

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptJul 21 2017, 1:36 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Srdjan added a subscriber: Srdjan.Jul 21 2017, 4:20 PM

Margin's coming from the .oo-ui-popupWidget-footer class. Maybe it's new? I guess Notifications should null it back out, at least for now.

Jdforrester-WMF renamed this task from Notifications flyout buttons have a design problem to Notifications flyout footer has an unwanted margin.Jul 21 2017, 5:13 PM

Probably a regression from rGOJUe5a613ea173d: WikimediaUI theme: Variablize PopupWidget values which added margin to the footer without justifying it in the commit message.

Change 366903 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/Echo@master] Fix layout regression in notification popup footer

https://gerrit.wikimedia.org/r/366903

Change 366903 merged by jenkins-bot:
[mediawiki/extensions/Echo@master] Fix layout regression in notification popup footer

https://gerrit.wikimedia.org/r/366903

Change 366952 had a related patch set uploaded (by Jforrester; owner: Catrope):
[mediawiki/extensions/Echo@wmf/1.30.0-wmf.10] Fix layout regression in notification popup footer

https://gerrit.wikimedia.org/r/366952

Change 366952 merged by jenkins-bot:
[mediawiki/extensions/Echo@wmf/1.30.0-wmf.10] Fix layout regression in notification popup footer

https://gerrit.wikimedia.org/r/366952

Mentioned in SAL (#wikimedia-operations) [2017-07-24T18:15:17Z] <reedy@tin> Synchronized php-1.30.0-wmf.10/extensions/Echo/modules/styles/mw.echo.ui.NotificationBadgeWidget.less: T171302 (duration: 00m 45s)

Catrope closed this task as Resolved.Jul 24 2017, 6:30 PM
Catrope claimed this task.
Johan added a subscriber: Johan.

(Since this minor problem was quickly solved.)

Johan removed a subscriber: Johan.Jul 27 2017, 7:08 PM