Page MenuHomePhabricator

[wmf.10] Long LTR article titles displayed cut off on the list of suggestions in RTL
Closed, ResolvedPublic

Description

  1. In hewiki go to Translation and select to translate from English to Hebrew
  2. Click 'Start new translation' and enter some short article title - 'Robot'. The suggestions will be displayed correctly (there is a typical issue with the order of parentheses) :
  3. Start typing the long article title - 'List of law clerks of the Supreme Court of the United States' - the beginning of the article titles gets cut off.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 21 2017, 7:58 PM
Amire80 edited projects, added RTL; removed Language-Team.Aug 6 2017, 2:28 PM
Amire80 added a subscriber: Amire80.

Mmmm... I'm afraid it's a bug in browsers, or even in the HTML spec, because it happens on a lot of otherwise well-behaving sites. But I'll try to take a closer look.

Restricted Application added a project: I18n. · View Herald TranscriptAug 6 2017, 2:28 PM
Arrbee assigned this task to Nikerabbit.Oct 27 2017, 6:29 AM
Arrbee triaged this task as Normal priority.
Arrbee moved this task from Needs Triage to Oct-Dec 2017 on the ContentTranslation board.
Arrbee added a project: Language-2017-Oct-Dec.

This is still present in the new article selector.

The problem is that the text doesn't have correct lang and dir attributes.

The title must definitely have lang and dir attributes of the target article.

I'm not sure about the Wikidata description; is it displayed in the user language or in the same language as the article title?

Is this the expected display?

This looks good. Is it with an RTL UI language?

Not sure about the placement of the "A文" icon—that's a question for Pau. In any case, it should be the same, and depend on the UI language and not on target article content language.

Yeah it's RTL ui selecting Finnish pages.

Change 389054 had a related patch set uploaded (by Nikerabbit; owner: Nikerabbit):
[mediawiki/extensions/ContentTranslation@master] Some RTL improvements to the page selector

https://gerrit.wikimedia.org/r/389054

santhosh updated the task description. (Show Details)Nov 6 2017, 11:12 AM

Change 389054 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Some RTL improvements to the page selector

https://gerrit.wikimedia.org/r/389054

Nikerabbit moved this task from In Review to QA on the Language-2017-Oct-Dec board.

Checked in cx-testing - looks good:

Etonkovidova closed this task as Resolved.Nov 30 2017, 11:36 PM
Nikerabbit moved this task from QA to Done on the Language-2017-Oct-Dec board.Dec 1 2017, 7:25 AM