Page MenuHomePhabricator

ERROR: "LBFactory::getEmptyTransactionTicket: WikiPageUpdater::injectRCRecords does not have outer scope"
Closed, ResolvedPublic

Description

Started with wmf.10. Presumably caused by https://gerrit.wikimedia.org/r/364094 / rEWBA24d45d6d0cfc: Wait for replication after adding RC entries in WikiPageUpdater

Logstash:
https://logstash.wikimedia.org/goto/709280746172b68115f62db346b06201

Wikimedia\Rdbms\LBFactory::getEmptyTransactionTicket: Wikibase\Client\Changes\WikiPageUpdater::injectRCRecords does not have outer scope.
#0 /srv/mediawiki/php-1.30.0-wmf.10/extensions/Wikidata/extensions/Wikibase/client/includes/Changes/WikiPageUpdater.php(161): Wikimedia\Rdbms\LBFactory->getEmptyTransactionTicket()
#1 /srv/mediawiki/php-1.30.0-wmf.10/extensions/Wikidata/extensions/Wikibase/client/includes/Changes/ChangeHandler.php(250): Wikibase\Client\Changes\WikiPageUpdater->injectRCRecords()
#2 /srv/mediawiki/php-1.30.0-wmf.10/extensions/Wikidata/extensions/Wikibase/client/includes/Changes/ChangeHandler.php(169): Wikibase\Client\Changes\ChangeHandler->applyUpdateAction()
#3 /srv/mediawiki/php-1.30.0-wmf.10/extensions/Wikidata/extensions/Wikibase/client/includes/Changes/ChangeHandler.php(137): Wikibase\Client\Changes\ChangeHandler->handleChange()
#4 /srv/mediawiki/php-1.30.0-wmf.10/extensions/Wikidata/extensions/Wikibase/client/includes/ChangeNotificationJob.php(99): Wikibase\Client\Changes\ChangeHandler->handleChanges()
#5 /srv/mediawiki/php-1.30.0-wmf.10/includes/jobqueue/JobRunner.php(293): Wikibase\Client\ChangeNotificationJob->run()
#6 /srv/mediawiki/php-1.30.0-wmf.10/includes/jobqueue/JobRunner.php(193): JobRunner->executeJob()
#7 /srv/mediawiki/rpc/RunJobs.php(47): JobRunner->run()
#8 {main}

See also:

Event Timeline

Krinkle created this task.Jul 22 2017, 2:30 AM
Restricted Application added a project: Wikidata. · View Herald TranscriptJul 22 2017, 2:30 AM
Restricted Application added subscribers: PokestarFan, Aklapper. · View Herald Transcript
Krinkle updated the task description. (Show Details)Jul 22 2017, 2:32 AM

Change 367328 had a related patch set uploaded (by Daniel Kinzler; owner: Daniel Kinzler):
[mediawiki/extensions/Wikibase@master] Move injection of RC records to a separate job.

https://gerrit.wikimedia.org/r/367328

daniel triaged this task as High priority.Jul 25 2017, 4:19 PM
daniel raised the priority of this task from High to Unbreak Now!.
daniel moved this task from Proposed to Review on the Wikidata-Former-Sprint-Board board.
Restricted Application added subscribers: Liuxinyu970226, Jay8g, TerraCodes. · View Herald TranscriptJul 25 2017, 4:19 PM
greg added a subscriber: greg.Jul 26 2017, 6:15 PM

Help! This thing is holding up 1.30.0-wmf.11 and needs review! review from folks who know about the JobQueue and deferred updates. @Krinkle? @aaron? The Wikidata team has little experience in this, especially with Addshore and Thiemo on vacation.

Change 367328 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Move injection of RC records to a separate job.

https://gerrit.wikimedia.org/r/367328

Change 368224 had a related patch set uploaded (by Daniel Kinzler; owner: Daniel Kinzler):
[mediawiki/extensions/Wikibase@wmf/1.30.0-wmf.10] Move injection of RC records to a separate job.

https://gerrit.wikimedia.org/r/368224

Change 368224 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@wmf/1.30.0-wmf.10] Move injection of RC records to a separate job.

https://gerrit.wikimedia.org/r/368224

Removing as blocker for wmf.11, does need a backport, but started with wmf.10, per IRC:

<DanielK_WMDE_> if wmf.10 of wikidata has been live without the patch for a week, there's no point in blocking on it now.
<DanielK_WMDE_> the error causes log spam, and database transactions get a bit strange, but nothing should be loast
<DanielK_WMDE_> *lost
Krinkle added a subscriber: demon.Jul 27 2017, 8:13 PM

Change 367328 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Move injection of RC records to a separate job.
https://gerrit.wikimedia.org/r/367328

Where do we need to cherry-pick this to so we can get it live? I see wmf.7 is the current Wikidata branch.

Change 368224 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@wmf/1.30.0-wmf.10] Move injection of RC records to a separate job.
https://gerrit.wikimedia.org/r/368224

The Wikibase extension isn't deployed. The Wikidata extension is, which needs to be rebuild in the wmf.10 branch (or something?) for it to take effect. And the wmf.10 branch in mediawiki would need to be updated to point to it.

I don't see it yet at: https://github.com/wikimedia/mediawiki-extensions-Wikidata/tree/wmf/1.30.0-wmf.10/extensions/Wikibase/client/includes/Changes

Current Wikidata commit in wmf.10 of mediawiki-core: 41db3da4c

Also not at https://github.com/wikimedia/mediawiki-extensions-Wikidata/tree/41db3da4c/extensions/Wikibase/client/includes/Changes.

Krinkle lowered the priority of this task from Unbreak Now! to High.Jul 27 2017, 8:13 PM

Change 368312 had a related patch set uploaded (by Addshore; owner: Addshore):
[mediawiki/extensions/Wikidata@wmf/1.30.0-wmf.10] WB: Move injection of RC records to a separate job.

https://gerrit.wikimedia.org/r/368312

Looks like jenkins is giving the patch a +2 now

mmodell added a subscriber: mmodell.

The patch appears to be merged on master but the wmf.10 cherry-pick is still open? I've added this as a blocker to wmf.12 since it's still open and I need to verify that the issue isn't affecting wmf.12 after I cut the branch tomorrow.

@mmodell the cherry pick is merged https://gerrit.wikimedia.org/r/#/c/368224/, but the patch for the Wikidata build hasn't been https://gerrit.wikimedia.org/r/#/c/368312/3. I don't know why - I guess it got stuck on jenkins.

To avoid the confusion that held up the train last week: that this is about branches of the wikidata build and the wikibase extension. This does not block core updates.

@daniel: Thanks, removing it from blocking

Change 368312 abandoned by Krinkle:
WB: Move injection of RC records to a separate job.

https://gerrit.wikimedia.org/r/368312

Change 369881 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Fix handling of coalesced changes in InjectRCRecordsJob

https://gerrit.wikimedia.org/r/369881

Just to be clear: it looks like there are fixes for this in wikibase master that made it into wikidata wmf.14 which made the branch cut for core wmf.14, so this shouldn't block wmf.14 train going to group1. This is the assumption I will be working under when I run the train in an hour or so.

Krinkle closed this task as Resolved.Aug 23 2017, 12:11 AM

Fixed. The hit rate dropped to 0 for this warning in Logstash as of August 17. (Presumably due to all wikis to 1.30.0-wmf.14)

mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:10 PM