Investigate possible misbehavior when exporting/backing up/purging membership applications
Closed, DeclinedPublic

Description

Membership application 23539 was created at 2017-07-18 03:38:27 and got purged at 2017-07-19 05:00:01. The export timestamp is null, but there is a data set in VEWA, which was created on Jul 21st. Most probably the dataset was exported after the data set got purged.

This needs investigation:

  • the condition whether to purge a data set is defined in database-purge.sh.js
  • the condition whether to export a data set and setting the export timestamp is defined in SpendenDumper.php
  • the purged data is kept as encrypted dumps and may help finding the problem
Restricted Application added a project: WMDE-Fun-Team. · View Herald TranscriptJul 24 2017, 11:29 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
kai.nissen renamed this task from MemberID 23539 is moderated but got exported. Why is data set on moderation? to Investigate possible misbehavior when backing up/purging membership applications.Jul 31 2017, 10:57 AM
kai.nissen updated the task description. (Show Details)
kai.nissen renamed this task from Investigate possible misbehavior when backing up/purging membership applications to Investigate possible misbehavior when exporting/backing up/purging membership applications.
gabriel-wmde claimed this task.
gabriel-wmde closed this task as Declined.Aug 16 2017, 6:25 PM

@tmletzko I Could not reproduce the moderation, neither blacklist matches nor fee is too high. The data should not be in the export file, as our timestamp indicates that it was never exported. Can you show us the export file with the empty data?

Since this is one unexplained incident and I've spent >5 hours without results, I'll be closing this.

@gabriel-wmde If I recall it correctly, the data set was exported because there was a valid donation data set. The membership of that person got moderated. But the personal data of the membership got purged. Maybe there is a misbehaviour when those related data sets got different status? Do you need the donation ID of the donation?

Maybe member ID 23539 is another case`?