Page MenuHomePhabricator

Recentchanges number of changes preference should have an upper limit
Closed, ResolvedPublic

Description

  1. On 'Preferences - Recent changes' change the "Number of edits to show in recent changes, page histories..." to really big number.
  2. The 'Save' page button can be clicked and no warning is displayed to a user. The number above the limit will be displayed as saved.

Note:

  1. The RC setting "Days to show in recent changes" will display the warning:

  1. 'Preferences -Watchlist' will display the warning (as above) for both 'Display options': "Days to show in watchlist" and "Maximum number of changes to show in expanded watchlist".
  1. On RC page the max limit for ""Number of edits to show in recent changes..." - 5,000 will be displayed.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 24 2017, 7:51 PM
Etonkovidova renamed this task from [minor] Preferences-Recent changes "Number of edits to show in recent changes, page histories..." allows to save a number bigger than the limit to [minor] Preferences-Recent changes "Number of edits to show in recent changes, page histories..." option allows to save a number bigger than the limit.Jul 24 2017, 7:52 PM
Catrope added a subscriber: Catrope.Aug 1 2017, 5:55 PM

There is no limit right now. Per T172026#3483291 there should be one.

Catrope renamed this task from [minor] Preferences-Recent changes "Number of edits to show in recent changes, page histories..." option allows to save a number bigger than the limit to Recentchanges number of changes preference should have an upper limit.Aug 1 2017, 5:56 PM

Let's limit it to 1000 for now, (and 500 later once we have pagination), for consistency with the watchlist limit.

Checked in 1.31.0-wmf.2 - the issue is fixed. The proper warning is displayed when a user attempts to save the bigger number than 1,000 for "Number of edits to show in recent changes, page histories..."

Etonkovidova closed this task as Resolved.Oct 10 2017, 7:46 PM