Page MenuHomePhabricator

When scrolling down in the list of results, the screen goes back to the top of the page
Closed, ResolvedPublic

Description

Since the deployment of the new version of the Query Helper, a display bug occurs.

When I open a query with a long list of results as this one, and try to scroll down to see the bottom of the list, I can't, and get automatically back to the top part of the screen (with Query Helper and text editor).

It happens even if the Query Helper is closed. But it doesn't happen all the time. It's blocking for browsing query results though.

Event Timeline

Restricted Application added a project: Discovery. · View Herald TranscriptJul 25 2017, 6:12 PM
Restricted Application added subscribers: PokestarFan, Aklapper. · View Herald Transcript

When I open a query with a long list of results as this one

Do you mean a query with a short list of results? Because if I understand the bug correctly, it only happens when the result list is short enough to fit on the screen when the query editor is hidden.

I also think this bug was fixed by I9c61d1f778 – we really shouldn’t have deployed the scrolling change without that fix (Jonas already noticed this bug in the change that introduced the scrolling behavior, Iced8251771).

Nikki added a subscriber: Nikki.Jul 26 2017, 10:05 AM

It's reproducible with long lists too in the right circumstances, e.g. set it to display 10 results at a time, run a query that returns thousands of results, resize the window so that the window is slightly shorter than the page and try to navigate through the results.

Well, okay, limiting the table to 10 results at a time is mostly like LIMIT 10 in the query, as far as this bug is concerned. The problem is that the full page is scrollable, but with the query box collapsed it fits on the screen without scrolling, so it keeps toggling between collapsing and expanding the query box.

Jonas closed this task as Resolved.Jul 31 2017, 6:34 PM